[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#412167: debian-installer: Rescue mode: install GRUB to floppy doesn't work

Package: debian-installer
Severity: normal

(This is from memory, please forgive minor errors in naming etc.)
Booting the net-inst CD in rescue mode and installing GRUB to (fd0) 
produces a floppy which on booting gave me a 'geom error'.
  From the amount of copying done (I later used grub-floppy to create a 
disk, which worked well), not all of the stage files were copied onto it.

Some details which may be important:
(hd0): SCSI drive with GRUB boot block in MBR and a single NTFS 
(hd1): Newly installed S-ATA drive with single NTFS partition
(hd2), shifted up from (hd1): Old P-ATA drive with several partitions, 
including ext3 root (containing /boot/grub/*stage* files) and swap.

I was trying to fix my system, which had become unbootable after I had 
installed an S-ATA controller and drive. Apparently this caused my 
drive numbers (hd1 and up) to shift up.
First, I tried to install GRUB onto (hd0), which failed, probably 
because GRUB had no place to write its stage files, and I saw no way to tell 
it where to do so.
Next I tried to write GRUB to a boot floppy, which wouldn't boot. 
Eventually I managed to enter a chroot from which I executed 
grub-floppy, which made a usable floppy.

Alain Kalker

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Reply to: