[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#394344: another Marvell Technology 11ab:6101 PATA Controller

Yes, another Debian Linux Kernel 2.6.17-2.6.18 Marvell Technology PATA Controller bug. A couple of others I found by searching for the pci id: 397062 and 407300.

Geert Stappers wrote:
Op 31-01-2007 om 13:27 schreef Jacob L. Anawalt:
Here is lspci -nn from the daily build dated 20070130:
02:00.0 IDE interface [0101]: Marvell Technology Group Ltd. Unknown device [11ab:6101] (rev b1)

Mmm, that PCI ID that did bring me
to http://www.ussg.iu.edu/hypermail/linux/kernel/0609.0/0272.html
which says:

A month later we have a patch that when applied to linux-2.6.19-rc1-mm1 enables support for the PATA interface in SATA mode.


I have been using it and it works well enough for my needs post-install. It looks like drivers/ata/pata_marvell.c is in 2.6.20-rc7.

I leave the honour to Marvell Technology Group.

Does that mean that there is no longer any doubt that this device will only work with kernel 2.6.17 if the ide stuff is not a module?

I looked at the source for linux-2.6-2.6.18.dfsg.1. I will try it when it is released, but there seems to be no driver to claim the Marvell 6101.


Reply to: