[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#407035: graphical installer crashes

If you create and format more than 2 partitions , installer crashes (SATA disk)

CC Vural

Attilio Fiandrotti wrote:
Joel Johnson wrote:
Package: installation-reports
Severity: important
Justification: after crashing, installer hangs starting partitioning task

Boot method: CD
Image version: installer build 20070109-03:51

Processor: AMD Athlon XP 2200+
Memory: 1GB
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       58688   471411328+  8e  Linux LVM
/dev/sda3           58689       60777    16779892+   7  HPFS/NTFS
/dev/sda4   *       60778       60801      192780   83  Linux

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]

Dragging GUI elements in the graphical installer can lead to a crash of the partitioning step. When this happens, the installer attempts to restart the task with "Starting up the partitioner" but hangs about mid-way through the status bar. Dragging a line appears to confirm or merge its actions with the target (dropping a line onto itself seems to select and confirm the action, which could be dangerous).

This has happened to me at multiple screens within the partitioner, I will follow up with exact lines to reproduce, I believe dragging the first hard drive line onto the blank line above triggers this.

The error printed on VC1 after the crash is (partially): "gtk_text_view_start_selection_drag: assertion failed: text view -> selection_drag_handler == 0"

Joel Johnson

I tried to reproduce the drag crash, but could not drag anything anywhere: could you please explain in the details what has to be dragged and how.



Reply to: