[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405196: Problem installing etch with debian installer and Marvell 88E8001 network hardware.

On Wednesday 03 January 2007 00:24, Frans Pop wrote:
> I suggest that you check the output of dmesg and the contents
> of /var/log/syslog (using 'nano') after switching to VT2 to see if that
> shows any reason that the driver is not working.

A warning appears in the log:

Warning **: MII ioctl failed for eth1

> The modules.pcimap for 2.6.18 shows two drivers for your ethernet card:
> skge and sk98lin. This is unusual.
> You can also try unload both these drivers (using 'modprobe -r') and then,
> after only loading one, check again if you can configure the network from
> the installer menu. 

This worked, using the following sequence during network device discovery I 
enabled the eth1 interface succesfully:

modprobe -r skge 
modprobe -r sk98lin
modprobe skge 

I completed the installation and rebooted, which kept networking enabled. But 
after rebooting both drivers were present again. Removing the skge interface 
disabled networking, removing the sk98lin module didn't do much. 

> Note that if you driver requires firmware (I don't know if it does or not)
> it may not be supported during the installation, and may also explain why
> Ubuntu does work as they have a different policy in that regard.

As it works now, I assume this isn't a problem.
> You could check which kernel version Ubuntu is using and which module is
> loaded during the Ubuntu installation for reference.

Ubuntu only loads the skge module. Assuming that the skge driver is the only 
one needed for this ethernet card, maybe the other one could be removed also? 
What is strange of course is that the combination of both modules works when 
starting the kernel, but doesn't work when installing debian. I will try to 
check if the order of installation matters. 

After applying the changes above, and rebooting I couldn't start up GDM, 
because a number of drivers weren't loaded/ installed, such as the  
xserver-xorg-input-mice, xserver-xorg-input-kdm packages. Also my video card 
wasn't detected (correctly). Could this be caused by the way I installed it 
now? Or should I enter another bug-report for this? 



Reply to: