[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405196: Problem installing etch with debian installer and Marvell 88E8001 network hardware.

Op 01-01-2007 om 18:07 schreef Geert-Jan Hut:
> ======================== lspci -vnn =============================
> 04:03.0 0c00: 1106:3044 (rev c0) (prog-if 10)
>         Subsystem: 1043:81fe
>         Flags: bus master, medium devsel, latency 64, IRQ 50
>         Memory at ff7ff800 (32-bit, non-prefetchable) [size=2K]
>         I/O ports at bc00 [size=128]
>         Capabilities: [50] Power Management version 2

Firewire controller

> 04:04.0 0200: 11ab:4320 (rev 14)
>         Subsystem: 1043:811a
>         Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 217
>         Memory at ff7f8000 (32-bit, non-prefetchable) [size=16K]
>         I/O ports at b800 [size=256]
>         Expansion ROM at 40000000 [disabled] [size=128K]
>         Capabilities: [48] Power Management version 2
>         Capabilities: [50] Vital Product Data

Ethernet controller

> ======================== lspci -vnn =============================

I think that was the output of `lspci -vn`
over here is the output of `lspci -vnn`

0002:20:0e.0 FireWire (IEEE 1394) [0c00]: Apple Computer Inc. UniNorth/Pangea FireWire [106b:0030] (prog-if 10 [OHCI])
        Subsystem: Apple Computer Inc. UniNorth/Pangea FireWire [106b:0030]
        Flags: bus master, 66MHz, medium devsel, latency 16, IRQ 40
        Memory at f5000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

0002:20:0f.0 Ethernet controller [0200]: Apple Computer Inc. UniNorth/Pangea GMAC (Sun GEM) [106b:0024]
        Flags: bus master, 66MHz, slow devsel, latency 16, IRQ 41
        Memory at f5200000 (32-bit, non-prefetchable) [size=2M]
        Expansion ROM at f5100000 [disabled] [size=1M]

(notice the description in words)

Please provide the output of

  lspci -s 04:04.0 -vnn

> Comments/Problems:
> This system is a newly built system, on which I tried to install Etch. Everything 
> went ok, up until the moment that I needed to select the network card. There 
> were two selections, one for the correct network card (Marvell Technology 
> Group Ltd. 88E8001 Gigabit Ethernet Controller) and one for a generic 
> network selection, something like 'Ethernet or Fast Ethernet'. I tried both, but 
> neither of the two worked, Which left me with a system without networking 
> connectivity. 

The "generic one" is your firewire controller.

> I also tried the Etch RC1 version, with the same behavior.
> First I suspected a hardware malfunction as the led's on the port were also off ,
> but networking with kubuntu works without a glitch. I first ran kubuntu as 
> a live-cd, it starts this way, you get a desktop button with which to install it. 
> After rebooting again in the debian minimal system - which was installed from 
> the netinst CD,  I had networking connectivity, and was for instance able to 
> run dhclient and get network settings configured. 
> I installed kubuntu on this system, just to make sure that it isn't something 
> related to a combination of sata / network issues (see bug #347412) but 
> this installation seems to work. 
> It looks like the installer someway messes up the network hardware during 
> detection, after which it isn't functional anymore. A simple reboot doesn't 
> solve the problem, only using software that also sets this network 
> configuration makes it working again. 
> I am testing with this system, so I am happy to retry the install or do any other 
> tests to verify/solve this problem. 

Okay fine.

It only takes GPL support for the Marvell 88E8001 network hardware,
but I have no idea how your hardware vendor thinks about it.

> Regards, Geert-Jan Hut.

Geert Stappers

Reply to: