[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#401392: Installation report AMD64 'testing' netinstall - part I

Package: installation-reports
Boot method: CD image
Image version: 'testing' netinstaller snapshot image 2006-11-30 (downloaded 2006-12-02) from debian.org
Date: 2006-12-03
Machine: PC
Processor: AMD Athlon 64 X2 dualcore
Memory:  2G RAM dual channel
Video: 256M nvidia GForce7200
Harddrive: 320G SATA II  'ST3320620AS'
Partitions: I try to create 1 prim -> 11 logical partitions including 2 x swap and a fat32, + 1 prim = /boot
User level: I'm experienced.


It was my intention to take as less care as possible, to test the installers
robustness. Accordingly, the installation didn't succeed.
This is a preliminary bug report - more to come soon. 
I hope i will have more luck tomorrow ;)


I just send you my manual logs, mainly usability notes.
I chose the graphical installer, got a nice screen and anything went 
fine, until the partitioner.


Manual partitioning

* keyboard navigation: the active buttons are not easy to recognize 
(no highlight color) it's a detail but creates a unsure feeling - really, that's
an unfortunate moment to tolerate that detail, at *partitioning* !

* I notice that installer offers some standard mountpoints. It would be nice 
if those already chosen would be omitted in that list.

* You really want to have MB the default when i enter just a number ?
I bet 99% of all AMD64 users partition anything in full G.
I missed to type 'G' repeatedly, leading to the below barfed issue.

* pressing 'back' one time too often throws me back to the beginning,
deleting my sophisticated partitioning table without warning ! Shit !
Strange enough, some values (m%, name, ..) seem to be remembered
 -> does it mean the partition table gets written immediately to disk, 
for every new partition ? I am used to it being written only if anything 
is complete...and why does the installer show an empty table at the 
second start then.

* Selecting an already completed partition, i can modify any setting but not 
the size. ... You see, that's the reason why i walked back at all in the above 
mentioned case, to search for that feature. A trap. Why do i have to *search* 
for a way to modify the size ? It should be there, in the main partition settings, 
as anything else. ... i checked it out now, you really want me to *delete* it !
Come on... that's really really uncool. 

(And don't tell me it can't be because the table immediately gets written, or
whatever. I know it can. You know it can.)


Failure stability and debug logging

* oops. After creating 11 sophistricated partitions, i pressed a wrong key 
(ESC one time too often ?) and GTK or whatever crashed: 5 seconds of silence,
where all buttons are blank, so no screenshot possible; with blank window content.
Then the main menu reappears. Choosing 'Create partitions' again, just leads to the 
same empty window. Nothing left from my precious table it seems ! 
And I can't go on.

I tried to save a debug log:

'Web' just went back to main menu. I already configured 
the network though. Maybe the card wasn't working?. No way to check that !

'Disc': Didn't try that, there's no floppy drive anyway (i bet 99% of AMD64 users....) 
and no dvd writer yet (would that have worked ?).

'Mounted Filesystem' leads to unresponsive system,with blinking white screen...
and here we are. Looks like i have to reboot.

Uhgh. I'm finished. (I admit i'm far too tired BUT isn't that the standard situation ?
For sysadmins. Anyway i can't remember it had been different any time....)

Enough for tonight....


* ps. There should be a feature to leave the graphical configurator, to enter a shell to 
track bugs (like, i still don't know if the network was reachable at all)

Reply to: