[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#384342: installation-report: doesn't boot kernel: Illegal Instruction (sparc)


* Jurij Smakov <jurij@wooyd.org> [2006-Sep-28 19:03 AKDT]:
> Can you please retry booting it with some recent image (like a recent
> daily)? In order to do any useful debugging I need to know exactly
> what image it was and what kernel version it was running, along with
> output of ctrace.

I just tried a daily I downloaded this morning.  It says it was built on
20060928.  Here's what happens when I boot:

    Allocated 8 Megs of memory at 0x40000000 for kernel
    Loaded kernel version 2.6.17
    Loading initial ramdisk (3526532 bytes at 0x21F802000 phys, 0x40C00000 virt)...
    Illegal Instruction
    ok ctrace
    PC: 404434
    Last leaf: jmpl  f0057da4    from 40004310
         0 w  %o0-%o7: (0 0 0 0 f0057da4 0 fff11701 40004310 )


(I typed the 'ctrace' part, but the rest comes from the booting

I also tried a 3.1r3 netboot mini:

    Allocated 8 Megs of memory at 0x40000000 for kernel
    Loaded kernel version 2.4.27
    Loading initial ramdisk (3027316 bytes at 0x400000 phyx, 0x40C00000 virt)...
    Remapping the kernel...

It never does anything else.  I have limited experience with Sun
hardware, so I don't know if all of this is pointing to a flaw in the
installers (which seems unlikely) or something busted-ass about the
hardware.  It has (and continues to) run Solaris 5.8 just fine, at least
as much as one can use the word "fine" in connection with Solaris.


Christopher S. Swingley          cswingle@iarc.uaf.edu
Intl. Arctic Research Center
University of Alaska Fairbanks   www.frontier.iarc.uaf.edu/~cswingle/

Reply to: