[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian installer with kernel 2.6.18

Hi there,

since I have a mainboard with VIA VT8251 chipset, I need an installer that
supports that chipset. It is contained in kernel 2.6.18, which is also
available as a debian package since today. 

No I tried to build my own installer with that kernel, as in
However I fail doing that.

I have changed the content of kernel-versions to

   # arch  abi       flavour        installedname           suffix   # build-depends
   amd64   2.6.18-2  amd64-generic  2.6.18-1-xen-amd64  - linux-image-2.6.18-1-xen-amd64

I also changed every occurrence of linux-image-2.6.16-2-amd64-generic to

But when I build the package, it fails:

marco@lurkabove:/tmp/k/linux-kernel-di-amd64-2.6$ dpkg-buildpackage -rfakeroot
dpkg-buildpackage: source package is linux-kernel-di-amd64-2.6
dpkg-buildpackage: source version is 1.11
dpkg-buildpackage: source changed by Frederik SchÃŒler <fs@debian.org>
dpkg-buildpackage: host architecture amd64
dpkg-buildpackage: source version without epoch 1.11
 fakeroot debian/rules clean
kernel-wedge gen-control > debian/control
dh_clean `find modules -type l`
 dpkg-source -b linux-kernel-di-amd64-2.6
dpkg-source: warning: missing information for output field Standards-Version
dpkg-source: warning: source directory `./linux-kernel-di-amd64-2.6' is not <sourcepackage>-<upstreamversion> `linux-kernel-di-amd64-2.6-1.11'
dpkg-source: building linux-kernel-di-amd64-2.6 in linux-kernel-di-amd64-2.6_1.11.tar.gz
dpkg-source: building linux-kernel-di-amd64-2.6 in linux-kernel-di-amd64-2.6_1.11.dsc
 debian/rules build
kernel-wedge gen-control > debian/control
 fakeroot debian/rules binary
kernel-wedge gen-control > debian/control
dh_clean -k
kernel-wedge install-files
        install -D -m 644 /boot/vmlinuz-2.6.18-1-xen-amd64 debian/kernel-image-2.6.18-2-amd64-generic-di/boot/vmlinuz
        install -D -m 644 /boot/System.map-2.6.18-1-xen-amd64 debian/kernel-image-2.6.18-2-amd64-generic-di/boot/System.map
        kernel-wedge copy-modules 2.6.18-2 amd64-generic 2.6.18-1-xen-amd64
missing module raid5
command exited with status 1
make: *** [binary-arch] Error 2

Any ideas what is going wrong here? Do I use the wrong source package? 


Marco Herrn              _  ___      o             '       (_)<   _ _
                         _>(__'>            o          0         (_X %
                                   >(_`>  O         o  _; _;'7^'_ \;\ %
(GnuPG/PGP-encrypted mail preferred)       _;\ _.\ _.';;) ;,;_/;
Key ID: 0x94620736                  _  _'./_\('))_; );/\)}/`fsc

Reply to: