[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#388572: apt-proxy woes during installation

Sorry if this is getting out of hand; I'm not experienced with reporting

In reply to Don Wright:

> The secret is to scroll to the top of the list of countries
> and pick "enter information manually".

That's not the issue. The issue is that it expects me to enter a
"server" and a "path" part of the URI with no hint how these are going
to be merged into a sources.list entry. Now my setup doesn't come with a
complicated URI, yet no combination seemed to work.

Eventually I had the idea to look at the generated sources.list file
after entering the data (darn obvious, yes, but it took me a few hours
to think of that) and I managed to enter the right data into the fields
that would result in a sources.list entry similar as to what I have on
working machines, namely

deb http://zwerg:9999/main/   etch   main

However, this still didn't work. The installer (or apt-setup or whatever
else is in charge at that time) connected to zwerg (or tried to, at any
rate) but never retrieved the file. Progress stalled completely (I've
filed another bug report about being unable to abort or cancel this).

Only *after* I manually killed the apt-get process, the following line
appeared in the log:
"Failed to fetch http://zwerg:9999/main/pool/main/p/popularity-contest/popularity-contest_1.34_all.deb Connection failed"

Interesting enough, switching to the other console I was able to
retrieve the file using wget. Why apt-get stalls and wget works is
beyond me; I've seen no further error message in the logs that would
give me a hint.

All this was using the debian-testing-amd64-netinst.iso from Wed,
20-Sep-2006. Things became a little more interesting when I tried the
debian-testing-i386-businesscard.iso from today (Fri 22-Sep-2006):

It would actually use my proxy to retrieve the base system, but when it
came to the "select and install software" step it would again stall as
described above.

Now, it may well be that my apt-proxy is responsible for all of this;
but I still blame the installer (or apt-setup or whatever) that it
doesn't come up with a helpful error message allowing me to track down
the actual problem.


Reply to: