[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#342053: DirectFrameBuffer crashes on PPC systems if HW accelerated drivers are used



On Fri, Sep 22, 2006 at 09:37:28AM +0200, Attilio Fiandrotti wrote:
> Sven Luther wrote:
> >On Thu, Sep 21, 2006 at 03:32:28PM +0200, Frans Pop wrote:
> >
> >>severity 342053 important
> >>thanks
> >>
> >>Lowering the severity of this bug to important.
> >>This issue is the main reason that g-i is only provided as experimental 
> >>mini.iso for powerpc. However, that does not make RC for the package as a 
> >>whole.
> >
> >
> >Notice: Do we have a proof that by disabling acceleration, the issue goes 
> >away ? 
> >I remember in extremadura that by booting the system by hand into text mode
> >and then launching the graphical mode made it work, so i am not sure that 
> >we
> >have only this as issue, not sure.
> 
> Last times the g-i was tested on PPC, it turned tout that
> 
>   Known good : radeonfb, vesafb (or whatever x86 uses).

vesafb is not built on powerpc, and the laptop we had in extremadura used a
radeon chipset, altough of the R300 variety.

>   Known bad : atyfb, nvidiafb
> 
> when acceleration was enabled.
> But that was with GTKDFB 2.0.9 and DFB 0.9.22, while now we have DFB 
> 0.9.25 and GTK 2.8.20 and many bugs got fixed.

And it will be better with gtk 2.10.x even, right ? 

> This is the most serious bug affecting g-i on PPC, and i wasn't able to 
> fix it because i have no PPC HW.

Yes, i will. Need to build a netboot g-i image and will test that on my
pegasos with the radon 9250 board.

> Sven, do you think can give the PPC g-i a try? i will help you on 
> debugging it as much as i can.

Indeed, that is my intentions, a first test today, and more over the week-end.

Friendly,

Sven Luther



Reply to: