[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#387877: Etch beta 3 and Compaq AlphaServer ES45



Package: installation-reports

Boot method: CD & netboot image
Image version: Etch beta 3
Date: 9/16/2006

Machine: Compaq AlphaServer ES45
Partitions: 


Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]

Booting ES45 from Businesscard CD or via netboot hangs before kernel
has a chance to output anything.

Businesscard image:

 P00>>>boot dqa0 -fl 1
 (boot dqa0.0.0.16.0 -flags 1)
 block 0 of dqa0.0.0.16.0 is a valid boot block
 reading 172 blocks from dqa0.0.0.16.0
 bootstrap code read in
 base = 32c000, image_start = 0, image_bytes = 15800(88064)
 initializing HWRPB at 2000
 initializing page table at 2ffff0000
 initializing machine state
 setting affinity to the primary CPU
 jumping to bootstrap code
 aboot: Linux/Alpha SRM bootloader version 0.9b
 aboot: switching to OSF/1 PALcode version 1.92
 aboot: booting from device 'IDE 0 16 0 0 0 0 0'
 aboot: no disklabel found.
 iso: Max size:12210   Log zone size:2048
 iso: First datazone:28   Root inode number 57344
 aboot: loading uncompressed boot/vmlinuz...
 aboot: loading compressed boot/vmlinuz...
 aboot: zero-filling 1139588 bytes at 0xfffffc0001514774
 aboot: loading initrd (4476370 bytes/4371 blocks) at 0xfffffc02ffac8000
 aboot: starting kernel boot/vmlinuz with arguments ramdisk_size=16384  root=/dev/ram devfs=mount,dall console=ttyS0
 (hangs here)
 
Netboot image:

 P00>>>boot eia0 -fl "root=/dev/ram ramdisk_size=16384 devfs=mount,dall console=ttyS0"
 (boot eia0.0.0.2.2 -flags root=/dev/ram ramdisk_size=16384 devfs=mount,dall console=ttyS0)

 Trying BOOTP boot.

 Broadcasting BOOTP Request for file: /tftpboot/etch_beta3_alpha.img
 Received BOOTP Packet File Name is: /tftpboot/etch_beta3_alpha.img
 local inet address: 192.168.0.25
 remote inet address: 192.168.0.1
 TFTP Read File Name: /tftpboot/etch_beta3_alpha.img
 netmask = 255.255.255.0
 Server is on same subnet as client.
 ................................................................
 ............................
 bootstrap code read in
 base = 32c000, image_start = 0, image_bytes = 5b8b6d(5999469)
 initializing HWRPB at 2000
 initializing page table at 2ffff0000
 initializing machine state
 setting affinity to the primary CPU
 jumping to bootstrap code
 aboot: Linux/Alpha SRM bootloader version 0.9b
 aboot: switching to OSF/1 PALcode version 1.92
 aboot: loading initrd (4573037 bytes/8932 blocks) at 0xfffffc02ffb90000
 aboot: starting kernel network with arguments root=/dev/ram ramdisk_size=16384 devfs=mount,dall console=ttyS0
 (hangs here)
 

Comments/Problems:

I tried the same procedures with VGA console, but it did not make any
difference.

I also tried Woody & Sarge CD-images, but it seems that their kernels
are compiled with CONFIG_ALPHA_LEGACY_START_ADDRESS=y and thus don't
work with ES45.

In desperation, I compiled the latest 2.6 kernel git snapshot (as of
yesterday) on my XP1000 which had Etch installed, moved the disk to
the ES45 and tried booting it, but still got the same hang!

The last thing I tried, was CentOS 4.3 CD and it seemed to work just
fine, so I do believe that there is something broken on Etch/Alpha
with the Titan systems (ES45, DS25). I'm not a kernel hacker in any
way, but it seems quite weird that even a self compiled kernel hangs
on boot. Could it be that aboot is broken somehow, or the kernel
is missing some patches that are required for ES45 support?

Thanks,

Eki



Reply to: