[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#378744: package: installation-reports

Package: installation-reports

Boot method: netinst CD
Image version:
Date: July 18 2006

Machine: custom built by myself, MSI MS-7025 / K8N Neo2 Platinum,
Nforce3 250Gb chipset
Processor: Athlon64 3200
Memory: 1GB
NOTE - one of the problems I have is that the partition table seems
to be corrupted!
NOTE2 - I have windows, Debian Etch AMD64, and I tried to install
Debian Etch x86.  The only partition for the x86 install is

Disk /dev/sda: 300.0 GB, 300069052416 bytes
255 heads, 63 sectors/track, 36481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           5       40131   83  Linux
/dev/sda2               6       12163    97659135    7  HPFS/NTFS
/dev/sda3           12164       36481   195334335    5  Extended
/dev/sda5           12164       24141    96213253+   c  W95 FAT32
/dev/sda6           24142       36299    97659103+  83  Linux
/dev/sda7           36300       36481     1461883+  83  Linux
sda1 - /boot for Etch AMD64
sda2 - C: for WXP SP2
sda5 - D:, FAT32 so it can be written from WXP and Linux
sda6 - / for Etch AMD64
sda7 - / for Etch x86 (this is the install I have trouble with)

Output of lspci and lspci -n:
root@0[knoppix]# lspci
0000:00:00.0 Host bridge: nVidia Corporation: Unknown device 00e1
(rev a1)
0000:00:01.0 ISA bridge: nVidia Corporation: Unknown device 00e0
(rev a2)
0000:00:01.1 SMBus: nVidia Corporation: Unknown device 00e4 (rev
0000:00:02.0 USB Controller: nVidia Corporation: Unknown device
00e7 (rev a1)
0000:00:02.1 USB Controller: nVidia Corporation: Unknown device
00e7 (rev a1)
0000:00:02.2 USB Controller: nVidia Corporation: Unknown device
00e8 (rev a2)
0000:00:05.0 Bridge: nVidia Corporation: Unknown device 00df (rev
0000:00:06.0 Multimedia audio controller: nVidia Corporation:
Unknown device 00ea (rev a1)
0000:00:08.0 IDE interface: nVidia Corporation: Unknown device 00e5
(rev a2)
0000:00:09.0 IDE interface: nVidia Corporation: Unknown device 00ee
(rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation: Unknown device 00e2
(rev a2)
0000:00:0e.0 PCI bridge: nVidia Corporation: Unknown device 00ed
(rev a2)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8
0000:01:00.0 VGA compatible controller: nVidia Corporation NV34GL
[Quadro FX 500] (rev a1)
0000:02:0c.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394
Host Controller (rev 46)
0000:02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8169 Gigabit Ethernet (rev 10)

lspci -n
0000:00:00.0 0600: 10de:00e1 (rev a1)
0000:00:01.0 0601: 10de:00e0 (rev a2)
0000:00:01.1 0c05: 10de:00e4 (rev a1)
0000:00:02.0 0c03: 10de:00e7 (rev a1)
0000:00:02.1 0c03: 10de:00e7 (rev a1)
0000:00:02.2 0c03: 10de:00e8 (rev a2)
0000:00:05.0 0680: 10de:00df (rev a2)
0000:00:06.0 0401: 10de:00ea (rev a1)
0000:00:08.0 0101: 10de:00e5 (rev a2)
0000:00:09.0 0101: 10de:00ee (rev a2)
0000:00:0b.0 0604: 10de:00e2 (rev a2)
0000:00:0e.0 0604: 10de:00ed (rev a2)
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:00.0 0300: 10de:032b (rev a1)
0000:02:0c.0 0c00: 1106:3044 (rev 46)
0000:02:0d.0 0200: 10ec:8169 (rev 10)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O ]
Configure network HW:   [O ]
Config network:         [O ]
Detect CD:              [O ]
Load installer modules: [O ]
Detect hard drives:     [O ]
Partition hard drives:  [E ]
Create file systems:    [O ]
Mount partitions:       [O ]
Install base system:    [O ]
Install boot loader:    [E ]
Reboot:                 [E ]

I'm not certain exactly where the problem is.  Here's what I did
and what happened.

what I did:
-boot etch beta 2 netinst image, hit enter at boot prompt
-manual partition
-erase existing swap partition, set type ext3, mount at /, format.
-do NOT install bootloader (already have one, I'll add this
-complete remaining 1 or 2 steps
-once the computer rebooted, I hit the power button - I had other
things to do
-boot computer, partition table not recognized
-use windows install disk to fix MBR, partition table still

The computer is set up so that when it boots, it first runs the
windows boot menu, and from there I can choose the "Linux" item to
run GRUB.  I used bootpart, http://winimage.com/bootpart.htm, to
add linux to the windows boot.ini.  Could this confuse the

I'm proceding with extreme caution.  The partition table is good
enough for both Windows Repair Console and for fdisk/cfdisk, yet
it's not good enough for the BIOS to boot the disk.

The only thing that should've changed with the partition table is
the type of /dev/sda7 - it went from swap to ext3.  I did not
delete or resize the partition.

I'm installing a 32bit version of Debian because of a program which
does not work on 64bit machines.  It requires hard real-time
(RTAI), which apparently does not work under 64-bit yet.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Reply to: