[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#352914: yaboot-installer tries to search for apple partitions on ibm rs6k/pseries hardware

On Thu, Jun 01, 2006 at 02:13:47PM +0200, "Nölle, Christian" wrote:
> Sven Luther wrote:
> > On Wed, Mar 08, 2006 at 02:29:13PM +0100, "Nölle, Christian" wrote:
> >> Sven Luther wrote:
> >>> On Tue, Feb 21, 2006 at 12:31:35PM +0100, "Nölle, Christian" wrote:
> >>>> Tried it today with the image from last night and the problem still
> >>>> persists. Installer is completly unusable. Maybe I should file a
> >>>> new bug?!
> >>> 
> >>> Nope, i am on it, but currently away at fosdem. I am experiencing
> >>> this same problem on my prep powerstack, this is a bug in
> >>> partman-prep/partman. I will work on this again on monday evening.
> >> 
> >> Does this bug still persist?! Any patches discovered?
> > 
> > We are still waiting for the beta2 to be finalized (any day now) to
> > fix this. I have patched the partman-prep package, so you could try
> > building it from the svn repo and use it there.  
> After we had lots of things to do beside our testing on that PPC we finally
> managed to get back on this issue. We still encounter that problem with
> the endless loop in the installer. Still not fixed, which makes it unusuable 
> for us.

Judging from your description earlier in this bug, this is entirely
unconnected to partman-prep or yaboot-installer; you say it's happening
right at the start of the installer, long before partman starts. I'm
slightly puzzled by your description, which for reference was:

  I just downloaded the daily-build from tonight (Version from the 02/15/2006)
  and gave it a try. Unfortenately it is totally unusable for us. Entering the
  expert64 video=ofonly (or alternativly expert64 - makes no difference) modus,
  the system boots up, enters the installer and results in autoselecting the
  language selection, exits it, enters it again, exits it....and so forth.

Could you clarify that when you boot using expert64, you don't even see
the installer main menu, but that it just goes straight into the
language selector without giving you any opportunity for interaction? If
that is the case, then it sounds as though kernel command-line options
aren't being passed through to the installer, which is very strange.
Could you try booting a current daily
(http://people.debian.org/~wouter/d-i/powerpc/daily/) with 'expert64
priority=low' to see what happens in that case?

(Sorry for the delay in replying to this; I was horribly busy at work
preparing a release, then I went on vacation for a week, then I was at a
conference for a week. I'm catching up now.)


Colin Watson                                       [cjwatson@debian.org]

Reply to: