[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#262531: marked as done (LVM LVs should be mounted as /dev/<VG>/<LV>)

Your message dated Fri, 23 Jun 2006 23:54:20 +0200
with message-id <20060623215420.GB19577@hardeman.nu>
and subject line LVM LVs should be mounted as /dev/<VG>/<LV>
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: built from svn, today
uname -a: i386
Date: <Date and time of the install>
Method: netboot

Machine: <Description of machine (eg, IBM Thinkpad R32)>
Root Device: LVM LV
Root Size/partition table: <Feel free to paste the full partition
      table, with notes on which partitions are mounted where.>
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O] see comments
Install base system:    [O]
Install boot loader:    [E] see comments
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


I tried to install Debian (testing) with root device on LVM.
Installation failed on boot loader installation step. First time d-i
offered to install grub. I returned to main menu to install lilo. lilo
installation failed. Problem is that root partition (VG vg01, LV
newroot) was mounted as /dev/mapper/vg01-newroot. LVM tools does not
understand logical volumes given in that format. Partition name should
be /dev/vg01/newroot (this file is really symlink to
/dev/mapper/vg01-newroot). d-i must not resolve such symlinks (resolved
name was also writen to /target/etc/fstab!).

After that I tryed to install d-i with low debconf priority. Before
bootloader installation step I unmounted /target and mounted it again
with command:

  mount -t ext3 /dev/vg01/newroot /target

Then I choosed to install lilo (into MBR). There was no messages about failed
installation. Screen just blinked. After that main menu appeared with
header in English and menu entries in Ukrainian. Messages in other
dialogs was in English (all messages are translated in Ukrainian in
normal install!). After reboot my old grub bootloader appeared, so lilo
was not installed.

Next try... After lilo install i ran:

 chroot /target /sbin/lilo (this code is in lilo-installer too)

Following messages appeared:

Warning: '/proc/partitions' does not exists, disc scan bypassed
Fatal: Sorry, don't know how to handle device 0xfe00

I did not seen such messages on any console before! I mounted
/target/proc and rerun this command. Some warings appeared, no error
messages. After reboot lilo loaded new Debian system.

--- End Message ---
--- Begin Message ---

grub and lilo currently support either way (/dev/VG/LV or /dev/mapper/VG-LV).

However, initramfs-tools and the packages which use it (e.g. cryptsetup) only support /dev/mapper/VG-LV.

I'm therefore closing this bug as the /dev/mapper syntax is supported by all programs while the other syntax is not.


--- End Message ---

Reply to: