[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#259825: marked as done (failed to properly configure existing debian installation)

Your message dated Fri, 23 Jun 2006 14:33:53 -0700
with message-id <E1FttHl-0006x3-Ha@spohr.debian.org>
and subject line Bug#259825: fixed in os-prober 1.12
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports


Debian-installer-version: 20040712 businesscard sid 
uname -a: Linux debian 2.4.26-1-686 #1 Sat May 1 18:04:05 EST 2004 i686 GNU/Linux 
Date: thu Jul 13 16:17:59 CEST 2004 
Method: I installed by booting from the businesscard sid CD. The base system
was installed from the network by using the ftp.fi.debian.org mirror. I didn't
use any proxy. 

Machine: Fujitsu Siemens Scaleo 
Processor: P3 1000MHz
Memory: 256MB RAM
Root Device: IDE /dev/hdb4 
Root Size/partition table:  
                              Disk Drive: /dev/hda
                        Size: 40020664320 bytes, 40.0 GB
              Heads: 255   Sectors per Track: 63   Cylinders: 4865

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
    hda1        Boot        Primary   W95 FAT32 (LBA)                  20012.11
    hda5                    Logical   Linux ext2       [my:media1]     20003.89

                              Disk Drive: /dev/hdb
                        Size: 61492838400 bytes, 61.4 GB
              Heads: 255   Sectors per Track: 63   Cylinders: 7476

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
                                      Unusable                             0,07*
    hdb3                    Primary   Linux ext2       [deb:/boot]        49,29*
    hdb5                    Logical   Linux swap                         254,99
                            Logical   Free Space                           0,04*
    hdb6        NC          Logical   Linux ext2       [deb:/]          8003,17*
                            Logical   Free Space                           0,04*
    hdb7        NC          Logical   Linux ext2       [deb:/home]      3997,46*
    hdb2                    Primary   Linux ext2       [my:media2]     47813,56
    hdb4        Boot        Primary   Linux ext3                        1274,92
                                      Unusable                            98,71

(hdb4 is the only partition used in the install and its mounted as /) 

Output of lspci and lspci -n:
debian:~# lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)0000:00:0a.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
0000:00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
0000:00:0c.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 08)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX
400] (rev a1)
debian:~# lspci -n
0000:00:00.0 Class 0600: 1106:0691 (rev c4)
0000:00:01.0 Class 0604: 1106:8598
0000:00:07.0 Class 0601: 1106:0686 (rev 40)
0000:00:07.1 Class 0101: 1106:0571 (rev 06)
0000:00:07.2 Class 0c03: 1106:3038 (rev 16)
0000:00:07.3 Class 0c03: 1106:3038 (rev 16)
0000:00:07.4 Class 0c05: 1106:3057 (rev 40)
0000:00:0a.0 Class 0200: 1113:1211 (rev 10)
0000:00:0c.0 Class 0401: 1102:0002 (rev 08)
0000:00:0c.1 Class 0980: 1102:7002 (rev 08)
0000:01:00.0 Class 0300: 10de:0110 (rev a1)

 System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


When I had decided how to partition my drive. That is I had made the hdb4
partition, the installer showed an error dialog that said something about too many
primary partitions but I choose to continue and it worked out fine.

When I booted the base-system after the installation it didn't use the language
I had set.
in the installation program I setup swedish as my language and keyboard, and the
installation continued with swedish translations. But when I booted the system to
boot my installed base-system it used english again when base-config started. I
was also unable to enter swedish characters (such as å, ä and ö) in the console. 
i managed to fix this by running: dpkg-reconfigure console-data and
dpkg-reconfigure locales. My settings was:

debian:~# debconf-show console-data | grep \*
* console-data/keymap/qwerty/swedish/variant: Standard
* console-data/keymap/qwerty/layout: Swedish
* console-data/keymap/family: qwerty
* console-data/keymap/policy: Select keymap from arch list

debian:~# debconf-show locales
* locales/default_environment_locale: sv_SE
* locales/locales_to_be_generated: en_US ISO-8859-1, sv_SE ISO-8859-1

Im not sure I was required to reconfigure console-data since I couldnt see any
improvements afterwards, but the reconfiguring of locales solved the problem.
I can now type swedish characters and programs are translated to swedish,
including base-config.

On my system I had two other OS:es installed before this one. Windows 2000 and
Debian (with two kernels). I could load Windows from the grub bootloader but 
I couldn't load my old Debian ones. When I tried to load them this text came up:

  Booting 'debian (on /dev/hdb6)'

root  (hd1,5)
 Filesystem type is ext2fs, partition type 0x83
kernel  /vmlinuz root=/dev/hdb6 ro noapic nolapic

Error 15: File not found

The same happend for my other kernel 'debian_old (on /dev/hdb6)' where grub
couldnt find /vmlinuz.old. Perhaps grub is having problem with my symlinks
since they point to files in the /boot directory that exist on another partition.

--- End Message ---
--- Begin Message ---
Source: os-prober
Source-Version: 1.12

We believe that the bug you reported is fixed in the latest version of
os-prober, which is due to be installed in the Debian FTP archive:

  to pool/main/o/os-prober/os-prober-udeb_1.12_i386.udeb
  to pool/main/o/os-prober/os-prober_1.12.dsc
  to pool/main/o/os-prober/os-prober_1.12.tar.gz
  to pool/main/o/os-prober/os-prober_1.12_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 259825@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Frans Pop <fjp@debian.org> (supplier of updated os-prober package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Fri, 23 Jun 2006 21:46:41 +0200
Source: os-prober
Binary: os-prober os-prober-udeb
Architecture: source i386
Version: 1.12
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Frans Pop <fjp@debian.org>
 os-prober  - utility to detect other OSes on a set of drives
 os-prober-udeb - utility to detect other OSes on a set of drives (udeb)
Closes: 258623 259825
 os-prober (1.12) unstable; urgency=low
   [ Joey Hess ]
   * Patch from VMiklos to sed off (hdn,n) from the front of a kernel path,
     as seen in SuSE grub configs. Closes: #258623 although this is fixed
     imprefectly since it assumes stripping the string is enough.
   * Patch from VMiklos to not require an initrd be specified in the grub
   * Patch from VMiklos to add --mounted option to linux-boot-prober.
     May not be useful for d-i but in other situations including for the
     Frugalware installer.
   [ Frans Pop ]
   * When parsing a lilo configuration, dereference symbolic links. Not doing
     this will break booting the old OS if the link was in / and there was a
     separate /boot partition. And grub in general prefers full paths.
     Closes: #259825.
   * Use environment variable to pass --mounted option to lower level scripts
     instead of perpetuating the parameter.
   * Add myself to uploaders.
 1ace43209fff58fb2e0b0a7936303889 638 debian-installer optional os-prober_1.12.dsc
 f01dd65e05a2d85480cd829568a102fb 13987 debian-installer optional os-prober_1.12.tar.gz
 6accb5364cd3666a8d57fe7fb82f389d 7456 debian-installer optional os-prober-udeb_1.12_i386.udeb
 73ff648a59f713734c8e513544aa1a72 11772 utils extra os-prober_1.12_i386.deb
Package-Type: udeb

Version: GnuPG v1.4.1 (GNU/Linux)


--- End Message ---

Reply to: