[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#261682: marked as done (installation-report: OS detection problems)

Your message dated Wed, 21 Jun 2006 22:04:46 +0200
with message-id <200606212204.47821.elendil@planet.nl>
and subject line Bug#289831: wrong grub config with additional linux installed/general feedback
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports


Debian-installer-version: build from SVN, 2004/07/27
uname -a: Linux intel4 2.4.26 #1 Срд Тра 26 19:53:34 EEST 2004 i686 GNU/Linux
Date: 2004/07/27
Method: using netboot initrd

Machine: <Description of machine (eg, IBM Thinkpad R32)>
Root Device: <IDE?  SCSI?  Name of device?>
Root Size/partition table:
part1               1        3648    29302528+   5  Extended
part2            3649        3953     2449912+  4f  QNX4.x 3rd part (QNX Momentix)
part3            3954        4870     7365802+  83  Linux   (new Debian system)
part5               1          37      297139+  82  Linux swap (swap for new and old Debian systems)
part6              38          81      353398+  83  Linux   (root of old Debian system)
part7              82        3648    28651896   8e  Linux LVM (old Debian System)
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


I installed unstable. There was no error in first stage. grub-installer
found my old Debian system (it was listed as Debian GNU/Linux ....). It did
not found QNX, but I do not think that it is a problem.

After reboot grub appeared with following menu:
Debian GNU/Linux, kernel 2.4.26-1-686
Debian GNU/Linux, kernel 2.4.26-1-686 (recovery mode)
QNX Momentix (on /dev/hda6)

There was no other Debian GNU/Linux listed in menu and /dev/hda6 device
is really root partition of old Debian system. That not only problem.
Commands for loading "QNX Momentix...":

root            (hd0,5)
kernel          /boot/vmlinuz-2.6.3 ro root=/dev/hda6
initrd          /boot/initrd.img-2.4.26-1-686

Kernel 2.6.3 was not default in old system. I am not sure that 
this kernel will boot with that initrd ;-)
My old grub.conf attached.

Booted new Debian system. During boot some program detected that
I have nvidia card and loaded framebuffer module. After that I had
3 cursors instead of one :-) (one big graphical cursor, and too small 
"cursors" on top of sreen with blue line). I do not think that
loading framebuffer module is really necessery.

During passwd configuration I was asked about my full name. I entered 
my name in Ukrainian. After that passwd suggested me my first name
as default value for login - will it work? :-)

timeout 5
default 0

title Debian GNU/Linux 3.0 (2.4.26)
	root (hd0,5)
	kernel /boot/vmlinuz-2.4.26 ro root=/dev/hda6 vga=771 video=vesa:800x600@8-100

title Debian GNU/Linux 3.0 (2.4.26-1-686)
	root (hd0,5)
	kernel /boot/vmlinuz-2.4.26-1-686 ro root=/dev/hda6
	initrd /boot/initrd.img-2.4.26-1-686

title Debian GNU/Linux 3.0 (2.6.3)
	root (hd0,5)
	kernel /boot/vmlinuz-2.6.3 ro root=/dev/hda6

title QNX Momentix
	root (hd0,2)
	chainloader +1

--- End Message ---
--- Begin Message ---
> Comments/Problems:
> everything worked fine beside the grub configuration was slightly wrong.
> The second linux on the hda8 was recogniced and two entries in the
> menu.conf generated, but the kernel root= parameter has been set wrong
> (set like the installation partition)

Sorry for responding so late to this report.
Unfortunately your original report is missing some important information 
needed to investigate this issue, like what the old bootloader was on 
your system and what the contents of the old configuration file 
(lilo.conf or grub's menu.lst) were.

As I'd guess you probably no longer have that info, I'm closing your 
report. If you still do have the old bootloader configuration, please 
send that by replying to this mail and we'll reopen the bug report.

We have made some corrections in the installer in the mean time and some 
more fixes will be uploaded very soon, so it is also possible that your 
problem is already fixed.

Thank you for sending your report.


--- End Message ---

Reply to: