[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#373586: PMac install - probs w/ finish install

I can confirm this problem ("finish install" doesn't finish the install - just flashes the screen and returns to the main menu) when installing on a PowerMac G4.

I saw it when installing directly from the June 12 jigdo DVD. I haven't had a chance to try the June 19th jigdo DVD just yet.


On Jun 14, 2006, at 8:06 AM, Jeffrey B. Green wrote:

Package: installation-reports


Debian-installer-version: 12 Jun 06 - testing (etch) jigdo cd(#1)
uname -a: Linux naro 2.6.15-1-powerpc #2 Mon Mar 6 12:39:17 CET 2006 ppc GNU/Linux
Date: 13 Jun 06
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?
Booted from the install cd into expert mode; did standard install with
	manual partitioning of the hard drive.

Machine: Apple G4 PowerMac with AGP
Processor: 7400, altivec supported
Memory: 640MB
Root Device: IDE Hard drive (/proc/.../model WDC WD1200BB-00CAA0)
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
Filesystem           1M-blocks      Used Available Use% Mounted on
/dev/hda7                  480       207       248  46% /
tmpfs                      315         1       315   1% /dev/shm
/dev/hda10               20159     16861      2274  89% /home
/dev/hda11               40610     27866     10681  73% /nfs
/dev/hda8                 5040      1886      2899  40% /usr
/dev/hda9                40318     31202      7069  82% /usr/local
tmpfs                      315         1       315   1% /dev

Output of lspci and lspci -n:

0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
0001:10:0d.0 PCI bridge: Digital Equipment Corporation DECchip 21154 (rev 05)
0001:11:02.0 SCSI storage controller: Adaptec AHA-7850 (rev 03)
0001:11:04.0 VGA compatible controller: ATI Technologies Inc Rage 128 RE/SG
0001:11:07.0 ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 02)
0001:11:08.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:11:09.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:11:0a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
0002:21:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal PCI
0002:21:0f.0 Ethernet controller: Apple Computer Inc. UniNorth GMAC (Sun GEM)

0000:00:0b.0 0600: 106b:0020
0000:00:10.0 0300: 1002:5046
0001:10:0b.0 0600: 106b:001f
0001:10:0d.0 0604: 1011:0026 (rev 05)
0001:11:02.0 0100: 9004:5078 (rev 03)
0001:11:04.0 0300: 1002:5245
0001:11:07.0 ff00: 106b:0022 (rev 02)
0001:11:08.0 0c03: 106b:0019
0001:11:09.0 0c03: 106b:0019
0001:11:0a.0 0c00: 104c:8019
0002:21:0b.0 0600: 106b:001e
0002:21:0f.0 0200: 106b:0021

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader: [ ] - kept config since I have a sarge install on that machine too Reboot: [E] - The "finish installation" step just flash a window coming up
				  and then return to the install menu. I had to finish via the
				  abort installation.

As above, a standard install though I skipped the Debian mirror part since I install packages from loop mounted DVD images (however even when I did specify a mirror, it didn't work...found the Release file but (the installer) tasksel couldn't seem to connect with the mirror). As a sidenote when I later tried to run tasksel after booting into the new system, that failed when it complained about answering yes to some questions when --force-yes wasn't given as an option.
The main problem happened at the end with the "finish install" step. As above it just
	flashed a window and returned to the menu.

(Package related issues) Although I specified shadow passwords, they were not set, probably because of the finish prob above. I did a shadowconf on to get it going. Also the timezone wasn't set...as above. I installed kdm,kde,&xorg via dselect. They didn't set a useable video mode for the machine (640x480 I believe). I needed to go in and set the HSync and VRefresh explicitly in the xorg.conf to get a useable display. Also KDE would not initialize sessions. In both a new user and an established user, it would start to initialize the session but then eventually return to the login screen. To get into something I could use, I escaped from the login screen into console mode, logged in root, killed kdm, and then did a startx. However, I could only do one startx. After that if I killed X and tried to get it going again, it
	would complain about an openoffice being open and then X would die.

Once you have filled out this report, mail it to submit@bugs.debian.org.

To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: