[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: powerpc daily sid_d-i CD builds working again

This one seems to have lost debian-boot, sending there.

On Mon, May 15, 2006 at 12:04:05PM +0200, Yves-Alexis Perez wrote:
> On Mon, 2006-05-15 at 08:39 +0100, Colin Watson wrote:
> > On Wed, May 03, 2006 at 08:58:06PM +0300, Eddy Petrişor wrote:
> > > On 5/3/06, Colin Watson <cjwatson@debian.org> wrote:
> > > >FYI, the daily sid_d-i CD builds are working again for powerpc. Sorry
> > > >for the long hiatus here! Among other things, those of you with tg3
> > > >network cards should be able to use these.
> > > >
> > > >  http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/powerpc/iso-cd/
> > > 
> > > Are you going to activate the G-I daily build, too?
> > 
> > Belatedly, yes, I'd already done so:
> > 
> >   http://people.debian.org/~cjwatson/d-i/powerpc-gtk/
> The installer boots fine (requires a patched yaboot to boot via tftp
> because of initrd.gz size). But then, when initialising graphical
> installer, it says:
> Framebuffer not available, disabling graphical frontend.

My analysis here, is that, since there is an output, we are already runnin in
some kind of framebuffer devices, either atyfb or offb probably.

So, the message seems to be in error, or something, i am not sure, didn't look
at the code. It is possible that it is i386 specific, and goes looking for
vesafb, but this doesn't explain why eddy was able to make it work (presumably
on a radeonfb based powerbook). I think i remember that we had some special
casing for radeonfb/powerpc somewhere.


Sven Luther

Reply to: