[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#245268: marked as done (failed to find bios drive for /dev/cciss/c0d0p4)

Your message dated Sun, 14 May 2006 20:57:43 -0300
with message-id <87y7x4i2h4.fsf@nurf.casa>
and subject line Should be fixed in current images of installer
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports


Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/daily/i386/20040421/sarge-i386-netinst.iso
uname -a: Linux debian 2.4.25 #1 SMP Sat Nov 1 04:54:10 CET 2003 i686 GNU/Linux (self-compiled kernel from another installation)
Date: Thu Apr 22 11:36:13 CEST 2004
Method: netinst cdrom

Machine: HP Proliant ML350 G3 (same as in #241237)
Processor: P4 Xeon 2.8 GHz
Memory: 2.5 GB
Root Device: /dev/cciss/c0d0p4
Root Size/partition table:  
Disk /dev/cciss/c0d0: 145.6 GB, 145667358720 bytes
255 heads, 32 sectors/track, 34866 cylinders
Units = cylinders of 8160 * 512 = 4177920 bytes

Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1               1           8       32624   83  Linux            # not used (working woody system)
/dev/cciss/c0d0p2               9        1205     4883760   82  Linux swap       # not used (working woody system)
/dev/cciss/c0d0p3            1206        5398    17107440    f  W95 Ext'd (LBA)  
/dev/cciss/c0d0p4   *        5399       34866   120229440   83  Linux            # /
/dev/cciss/c0d0p5            1206        2402     4883744   83  Linux            # not used (working woody system)
/dev/cciss/c0d0p6            2403        2881     1954304   83  Linux            # not used (working woody system)
/dev/cciss/c0d0p7            2882        5275     9767504   83  Linux            # not used (working woody system)
/dev/cciss/c0d0p8            5276        5398      501824   82  Linux swap       # swap

Output of lspci and lspci -n:
debian:~# lspci -n
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Class 0600: 1166:0014 (rev 32)
0000:00:00.1 Class 0600: 1166:0014
0000:00:00.2 Class 0600: 1166:0014
0000:00:02.0 Class 0100: 9005:00c0 (rev 01)
0000:00:02.1 Class 0100: 9005:00c0 (rev 01)
0000:00:03.0 Class 0300: 1002:4752 (rev 27)
0000:00:04.0 Class 0200: 14e4:16a6 (rev 02)
0000:00:05.0 Class 0880: 0e11:a0f0
0000:00:0f.0 Class 0601: 1166:0201 (rev 93)
0000:00:0f.1 Class 0101: 1166:0212 (rev 93)
0000:00:0f.2 Class 0c03: 1166:0220 (rev 05)
0000:00:0f.3 Class 0600: 1166:0225
0000:00:11.0 Class 0600: 1166:0101 (rev 05)
0000:00:11.2 Class 0600: 1166:0101 (rev 05)
0000:02:02.0 Class 0104: 0e11:0046 (rev 01)
0000:05:02.0 Class 0604: 8086:b154
0000:06:04.0 Class 0200: 8086:1229 (rev 08)
0000:06:05.0 Class 0200: 8086:1229 (rev 08)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

Grub installation failed. 
>From messages:
Selecting previously deselected package grub.
(Reading database ... 9141 files and directories currently installed.)
Unpacking grub (from .../grub_0.93+cvs20031021-8_i386.deb) ...
Setting up grub (0.93+cvs20031021-8) ...
Probing devices to guess BIOS drives. This may take a long time.
/dev/cciss/c0d0p4 does not have any corresponding BIOS drive.

>From syslog:
Jul 25 19:38:55 (none) user.notice grub-installer: info: Installing grub on '(hd0)'
Jul 25 19:38:55 (none) user.notice grub-installer: info: grub-install support --no-floppy
Jul 25 19:38:55 (none) user.notice grub-installer: info: Running chroot /target /sbin/grub-install --no-floppy "(hd0)"
Jul 25 19:38:55 (none) user.notice grub-installer: error: Running 'grub-install --no-floppy "(hd0)"' failed.
Jul 25 19:38:57 (none) user.warn main-menu[279]: WARNING **: Configuring 'grub-installer' failed with error code 1
Jul 25 19:38:57 (none) user.warn main-menu[279]: WARNING **: Menu item 'grub-installer' failed.

I also tried a lilo install, but this failed, I guess because lilo was not installed.

Reboot using the kernel from an already installed woody system worked fine, and base-config gave no problems. The woody install causes the weird partition layout I used, which probably caused the grub failure.

I chose LANG_INST="en_US" and LANGUAGE_INST="en", which made the timezone chooser default to US timezones, which was not what I wanted. Language and timezone should not be related.

I probably will be unable to test d-i any further on this system. We will need it for other purposes from now on. I do have the log files available if anyone wants them.


--- End Message ---
--- Begin Message ---

Looks like your bug is fixed in current installer. Would be good if
you could see if it still reproducable and reopen the bug in case.

Thanks in advance,

p.s.: You can get a new installer image in

        O T A V I O    S A L V A D O R
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://www.freedom.ind.br/otavio
"Microsoft gives you Windows ... Linux gives
 you the whole house."

--- End Message ---

Reply to: