[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#366177: [amd64] Tyan S2877 installation-report

Retitle 366177 [amd64] Tyan S2877 installation-report
Tags 366177 moreinfo

On Fri, May 05, 2006 at 04:27:02PM -0500, Karl Schmidt wrote:
> Package: installation-reports
> Boot method: <tried various testing boot netinstall and card install ISOs>
> Image version: <May 3 2006 >
> http://cdimage.debian.org/cdimage/etch_di_beta2/amd64/iso-cd/debian-testing-amd64-businesscard.iso>
> Date: <May 3-5 2006>
> Machine: <Tyan S2877>
> Processor: Dual AMD OSA265C
> Memory: 4 1 Gig sticks (to support 128bit)

Can I loan such machine for a few weeks?

> Partitions: <Partition data/>
> Output of lspci and lspci -n: <
> Base System Installation Checklist:
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Initial boot worked:    [O]
> Configure network HW:   [O]
> Config network:         [E]
> Detect CD:              [E]
> Load installer modules: [O]
> Detect hard drives:     [O]
> Partition hard drives:  [E]
> Create file systems:    [E]
> Mount partitions:       [O]
> Install base system:    [E]
> Install boot loader:    [ ]
> Reboot:                 [ ]
> Comments/Problems:
> <
> Would not DHCP correctly until I booted with Knoppix and it created a lease 
> file.  I could see the requests on the DHCP server, looked like the MAC 
> address was incremented by 1 from what it really was?? Very strange. There 
> are two NICs on this MB - the first one is nvidia and the second Broadcom

Connect both NICs to the switch to find which one works for the standard
Debian kernel. (Knoppix uses another kernel)
Also allow your DHCP server to reply to all MAC addresses ( revert
the change when you have found out what goes wrong )

About that  "MAC+1":
Could that be a maintiance port? ( a.k.a. "Remote support card" ?)

> From Tyan's web site :
> ??? One Broadcom BCM5705 GbE LAN (G2NR)
>     - One RJ-45 LAN connector with LEDs
>  ??? One Marvell 88E1111 GbE PHY
>     - One RJ-45 LAN connectors with LEDs
> I don't think this is correct?? etho is a nvidia ck804 and the one that 
> will work (after there is a lease file) and eth1 is the broadcom that would 
> never work. Note they are listing the  Marvell as PHY instead of a Lan 
> device --
> see http://en.wikipedia.org/wiki/PHYceiver
> I'm not sure I understand - could be two physical devices for the same 
> eth0???

No. (Being eth0 a device known by the running kernel.)
But AFAIK can "MAC" and "MAC+1" be on the same physical connector.
"MAC" will be come eth0 for the kernel and "MAC+1" will never been seen
by the kernel.

Note that is this very hardware specific.
If I have physical access to this hardware, I could have a closer look.

> The drivers seem to be forcedeth and tg3
> 0000:00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
> 0000:01:06.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705_2 
> Gigabit Ethernet (rev 03)
> Could be that the nvidia part just bridges the Broadcom controller with the 
> PHY interface chip?? There is a bridge enabled setting in the BIOS.

Interresting question. Please realize that you are the one that has the
hardware and it's documentation ....

> Next error:
> Would not boot from the SATA CD/DVD plextor drive (px-755SA) - not a big 
> deal - so I put in an older IDE drive for now.  (note not a problem in 
> Knoppix 4.0)

I think that is http://wiki.debian.org/DebianInstaller/SataAtapiHowto

> [ RAID ]
> Next error:
> On installation of base system it would complain that there was no /proc - 
> I created one by hand and that error went away.

Hmm, that could be a "not yet reported AMD64 thingy" ...

> Next error:
> It would fail at installing base-passwd - complains about missing file or 
> directory during a tar. I checked and all the mount points were there and 
> all the directories used exist??  This one Is the show stopper for me - any 
> hints??

Provide more information, like the name of the file that is missing.

> Next error:
> Would not create a /dev/sdxx for a usb drive I was going to use to transfer 
> error logs from.  I used ssh instead.
> Comment:
> IMHO it would seem like a good idea to have a build version in the name of 
> the ISO.

I known what you mean. (Sorry, no further comment )

> A Install report script might also be a good idea.

Yes. We have it implemented allready. It is at the bottom of the
installation menu.

> If I can be of help with further testing let me know - I don't have this 
> one up and running yet.

Just reply to this E-mail.

Geert Stappers

Reply to: