[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#365687: installation-reports

Package: installation-reports

Boot method: netinst CD	
Image version:
Date: 4-27-6 04:30

Machine: Compaq ProLiant ML350
Processor: 2 x 933MHz Pentium III

voxluna@amphion:~$ df -Tl
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
          reiserfs    15919636    332184  15587452   3% /
tmpfs        tmpfs      516776         0    516776   0% /dev/shm
              ext2       45863      8904     32065  22% /boot
              ext2      914108        14    816610   1% /tmp

Output of lspci and lspci -n:

voxluna@amphion:~$ lspci
0000:00:00.0 Host bridge: Broadcom CNB20LE Host Bridge (rev 05)
0000:00:00.1 Host bridge: Broadcom CNB20LE Host Bridge (rev 05)
0000:00:01.0 PCI bridge: Digital Equipment Corporation DECchip 21152
(rev 03)
0000:00:03.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB
1.1 Controller (rev 50)
0000:00:03.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB
1.1 Controller (rev 50)
0000:00:03.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
0000:00:0f.0 ISA bridge: Broadcom OSB4 South Bridge (rev 4f)
0000:00:0f.1 IDE interface: Broadcom OSB4 IDE Controller
0000:01:04.0 SCSI storage controller: LSI Logic / Symbios Logic
53C896/897 (rev 05)
0000:01:04.1 SCSI storage controller: LSI Logic / Symbios Logic
53C896/897 (rev 05)
0000:01:05.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet
Pro 100] (rev 08)
0000:01:06.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC
215IIC [Mach64 GT IIC] (rev 7a)
0000:01:07.0 System peripheral: Compaq Computer Corporation Advanced
System Management Controller
0000:05:02.0 PCI bridge: IBM IBM27-82351 (rev 07)
0000:06:00.0 Mass storage controller: Compaq Computer Corporation
Smart-2/P RAID Controller (rev 03)

voxluna@amphion:~$ lspci -n
0000:00:00.0 0600: 1166:0009 (rev 05)
0000:00:00.1 0600: 1166:0009 (rev 05)
0000:00:01.0 0604: 1011:0024 (rev 03)
0000:00:03.0 0c03: 1106:3038 (rev 50)
0000:00:03.1 0c03: 1106:3038 (rev 50)
0000:00:03.2 0c03: 1106:3104 (rev 51)
0000:00:0f.0 0601: 1166:0200 (rev 4f)
0000:00:0f.1 0101: 1166:0211
0000:01:04.0 0100: 1000:000b (rev 05)
0000:01:04.1 0100: 1000:000b (rev 05)
0000:01:05.0 0200: 8086:1229 (rev 08)
0000:01:06.0 0300: 1002:4756 (rev 7a)
0000:01:07.0 0880: 0e11:a0f0
0000:05:02.0 0604: 1014:0022 (rev 07)
0000:06:00.0 0180: 0e11:ae10 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [E]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [E]


1) Using "expert", if I format a partition as XFS, and then choose to
install a 2.4 kernel, the XFS module fails insmod after initial reboot,
and it panics.  Note that when using "expert24" to boot the netinst CD
(thus not using a 2.6 kernel during installation), you don't see XFS as
an available filesystem.  Maybe this is obvious to some people, but it
took me a while to figure out why it happened.

2) Starting an install using a 2.6 kernel, I never was able to load the
cpqarray driver properly to allow the / partition to be mounted after
the initial reboot, and thus finalize the installation.  The error says
"/dev/ida!c0d0p4 does not exist, dropping to shell".  Although the info
at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=251905 suggests a
problem with Grub, the bug report refers to software/LVM, not hardware
RAID (which I have).

  If Grub IS the problem, then you can't install LILO + 2.6:

3) Even though LILO is given as an option in "expert" mode, you can't
install it as bootloader in 2.6, you just get a red screen.

Also, I found this in the Debian-Installer FAQ:

	Q: What about SMP support?

	A: ...it would be nice if SMP was automatically detected and
	the appropriate kernel was chosen ... The installer attempts
        to do this. If it fails to notice that it needs a SMP kernel
	on your machine, please file a detailed installation report.

It did not install an SMP kernel.  But, consider that I couldn't finish
the 2.6 install due to #2 above, and thus I was using "expert24"; maybe
it would have done otherwise. Further, I didn't install any software with tasksel, not even "standard system". Later, I WAS able to "apt-get linux-image-686-smp" which is now running:

voxluna@amphion:~$ uname -a
Linux amphion 2.4.27-2-686-smp #1 SMP Wed Nov 30 21:47:06 JST 2005 i686

  .''`.      Jeff Bonner, PO Box 401 Highland MI 48357 USA
 : :'  :    PGP Key ID 0x6CEE42AA  248-318-4706 (Mobile/SMS)
 `. `'`    -=---------------------------------------------=-
   `-         "A witty saying proves nothing" - Voltaire

Reply to: