[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#361180: Debian installer doesn't install kernel

Package: installation-reports

Debian-installer-version: www.debian.org/devel/debian-installer 2006-0406
daily build
uname -a: Not available.  Boot failed.
Date: 20060406 1800
Method: <How did you install?  Network, with 3C905 card, DHCP
	What did you boot off?  Floppies
	If network install, from where? ftp.us.debian.org    Proxied?  No>

	Install command was:
		expert hw-detect/start_pcmcia=false

Machine: HP Vectra VL
Processor:  Pentium 2
Memory:  128 MB
Root Device:   /dev/hda2
Root Size/partition table: 
	/		/dev/hda2	5 GB
	/var		/dev/hda6	3 GB
	/usr/local	/dev/hda8	1 GB
	swap		/dev/hda9	512 MB
	/data		/dev/hda10	54 GB
Output of lspci:

0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:06.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
0000:00:10.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 03)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


	At reboot, the GRUB screen listed only "Other operating systems",
showing the kernel previously installed in /dev/hda1.  It didn't list the
newly installed kernel.
	Booted the previously installed system in /dev/hda1 (Debian Sarge,
kernel 2.6.8-686).  Mounted /dev/hda2 and examined /boot on that partition. 
No kernel, initrd, or System.map files present, only a grub directory.  The
progress bars said it was installing the kernel, but it's not there.

During install:
Selected linux-2.6.15-1-686
Selected initramfs-tools
Selected Debian popularity contest
Selected print server, DNS server, mail server, standard system.  Deselected
desktop environment.



Selected kernel-image-2.6-686
Selected initramfs-tools
Got: "Retrieving and installing the kernel - retrieving and installing
Deselected Debian popularity contest, but it installed anyway
Deselected desktop environment
Deselected standard system
Didn't select any other tasks

Same result as before.  Also checked /var and /tmp.  Empty.  Grepped the
whole partition for vmlinuz.  Not there.

Reply to: