[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian and others installation

I have recently attempted to install the debian-net-install, Ubuntu 5.1, Kubuntu 5.1 and Knoppix 4.0 on separate occasions but to the same machine.  The machine is not very fancy, FIC VA503+, 500-K62 and 384 MB.  I would like to report problems I had.  I get many comments that the VA503 board is trash, but they (I have 2) have worked well for me.  After service pack 6A, NT started to lock up on it, so I went to Win2K but after a service pack I started getting lock-ups again where it appeared that the IDE controller did not respond.  Linux has worked well, as Knoppix will run for months before I reboot.

1) I have a HP PSC 1315 printer attached to a USB 2.0 PCI card, and all recent Debian based versions died during the install as long as the printer was plugged in.  A message came up about initializing or checking the USB and that was the end.  There were no errors: it just never did anything else.  If I unplugged the printer and hit the reset button, all would work.  I refused to do that on Knoppix 4.0 (it is bogus fix), so I am back at Knoppix 3.8.

2) The Debian net-install did not set X up so that I could use the features of my monitor.  The greatest resolution it would give was 800x600 (I tried the reconfig thing for X later and it never changed the settings).  I had the etc directory from a Knoppix 3.8  install so I copied the X configuration files from it to get the resolutions I expected.  The Debian file seemed to be missing quiet a few lines.

3) I had changed from a PCI network card to a 3c515 card in order to add another IDE PCI controller.  None of the versions found the 3c515.  The net-install used it, but there was no network connections on subsequent reboots.  When I reinstalled Knoppix 3.8, it did not find it either, so I had to add my own script to do a “modprobe 3c515” and “ifup eth0” on every start-up.  Suse 10.0 and Fedora 4 find the network card. I think I answered the Suse question about my workgroup incorrectly so it would never use the card, but ifconfig always showed it.  Debian’s network configuration seems a lot better.

4) I have a Sound Blaster SBAWE-64 ISA card.  This card is never seen during install or boot (Suse and Fedora do see it).  So I added a “modprobe snd-sbawe” (I think it is correct) to my start-up script.


Soapbox time.  I have written software and I do not understand how Linux can be so finicky.  I would think that the installation would be tested using idiots like me to verify that it is going to work.  My wife thinks I am nuts: her windows pc just keeps running and I am always having to do something to fix a problem on the Linux pc.  I have the HP PSC 1315 connected to the Linux box because xsane works so much better and is so much faster than the HP application running on the Win2k box and I have the process to get windows to print to the Linux PC down to a science.  I had Samba working great on my Fedora 4 install, but I am going to spend hours (that I should be spending on something else) trying to get it right on Knoppix (it does not log into the windows machines properly).


Good Luck



Reply to: