[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Installer - boot floppies

On Sat, Feb 25, 2006 at 11:38:55PM +0800, Tomasz Grzegurzko wrote:
> Hi Sven,
> I've been trying to coax the floppy images from
> http://people.debian.org/~luther/d-i/images/daily/powerpc/floppy/
> (where daily = 25/2/2006) to boot on a 7200/75 I've picked up. The 
> system boots of the disks fine, which many of the earlier revisions of 
> the images do not (the ones pointed to by the debian documentation only 
> contain seemingly empty disk images, weird). Other times, I've inserted 
> the boot disk and after loading it up the screen blanks and will not 
> switch back on. However, my issue with the daily set from above is the 
> floppy module. It seems that the module "floppy" will not load either 
> from the installer or via a modprobe.
> # depmod -a
> # modprobe floppy
> FATAL: Error inserting floppy 
> (/lib/modules/2.6.15-1-powerpc-miboot/kernel/drivers/block/floppy.ko): 
> Device or resource busy
> # dmesg | tail
> register_blkdev: cannot get major 2 for fd

Ok, we need to investigate this, i am at fosdem, where i picked up a prep box
and another oldworld, and will be back home only wednesday and probably not
have time until next WE, but i will definitively try a run of those.

> Now I've tried an earlier set of disks based around
> /~luther/d-i/images/2005-11-09
> and they do not exhibit this floppy problem, but I cannot get through 
> the installation as the kernel modules for critical things such as the 
> ext2 file system cannot be loaded from archives as they do not exist in 
> the repos for stable, testing or unstable anymore.

Ok. This means that something broke in the kernel bewteen both. do the
2005.11.09 have 2.6.14 kernels, right ? 

> The unit has 40MB of ram and I am told that the system is going to 
> operate in lowmem mode, which seems to affect very little. I've checked 
> free at repeated points throughout and always seen ~20MB of ram free. 
> The ethernet and scsi modules are mace and mac53c94, which work out of 
> the older 2005-11-09 disk set but I cannot test under this later disk 
> set as I can't load the modules from the floppys I've made!
> Also, throughout the process I've tried various other disk sets and 
> notice from time to time a particular disk may break the 1.44MB barrier, 

Sure, but this should be fixed now. We had a serious problem about this.

> can I safely interpret that these are problematic disk sets and should 
> be avoided? I've tried to dd these disks and (as expected) run out of 

Yes, they will not work at all.

> space on the target disk when using /dev/fd0 (will superformatted 
> floppies work on this old mac -- unknown, but I am guessing these disks 
> have some kinds of errors perhaps?).

I believe not.

> Sorry to contact you direct if the right thing to do was post on a list; 

The list would have been the better place, i will CC this there.

> I'm happy for this to be repeated on whatever appropriate list for 
> others to muse over. I should also mention it's entirely possible I've 
> overlooked something fundamental as I will admit I only have limited 
> experience in both PPC architecture and Linux/MacOS on PPC architecture, 
> so messing around with the openrom firmware is something I've avoided 
> doing, but perhaps this is why the process is all going pear shaped, 
> although the fact that some disk sets work tends to dismiss this.

No, the powerpc oldworld miboot floppies have not worked since a long time,
and are a bit raw right now, so there is work needed to make them clean again.
I am happy to see you participating in that quest.

You should also file bug report for individual issues, the above should
probably be filled against linux-2.6, i think.


Sven LUther

Reply to: