[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#351805: installation-report: after reboot eth0 and eth1 are swapped

On Tue, Feb 07, 2006 at 05:07:45PM +0100, Joan Queralt wrote:
> Subject: installation-report: after reboot eth0 and eth1 are swapped
> Package: installation-reports
> Version: 2.9
> Severity: normal
> -- Package-specific info:
> Boot method: CD
> Image version: Debian-Installer etch beta1
> Date: Tue, 07 Feb 2006 12:00:00 +0100
> Machine: HP Compaq dc7600
> Partitions:
>  S. fitxers   Tipus  Blocs   1K     Usats   Lliures  %?s Muntat en
> /dev/sdb3     ext3    28834744   2507092  24862928  10% /
> tmpfs        tmpfs      514124         0    514124   0% /dev/shm
> tmpfs        tmpfs      514124       108    514016   1% /dev
> Base System Installation Checklist:
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Initial boot:           [O]
> Detect network card:    [E]
> Configure network:      [E]
> Detect CD:              [O]
> Load installer modules: [O]
> Detect hard drives:     [E]
> Partition hard drives:  [O]
> Create file systems:    [O]
> Mount partitions:       [O]
> Install base system:    [O]
> Install boot loader:    [O]
> Installed system ok:    [O]
> Comments/Problems:
> There were many problems during this installation. Cronologically:
> - The keyboard (PS/2) doesn't work if the mouse (USB) is plugged when
> booting. This applies to the installer itself and to the installed
> system. This issue is resolved when using the 2.6.15 kernel.

Sounds like a bug in the BIOS's legacy support.  Mouse and keyboard
legacy emulation should be independant.  Many bios's get this wrong.
Turning off legacy support entirely in the bios may help since you don't
need to emulate a ps2 keyboard and the mouse doesn't need legacy
support since the boot loader doesn't care about the mouse.

> - The network card, an Integrated Broadcom NetXtreme Gigabit Ethernet,
> wasn't detected automatically. It worked after loading the tg3 module.

Hmm, no idea.  I try to avoid broadcom.

> - This is the main problem. The installer detected two network
> interfaces: a firewire and the ethernet card and assign them the eth0
> and eth1 names respectively.
> Since there is nothing connected to the firewire, we chose eth1 as the
> main interface. However, after rebooting, the system swapped the names
> and eth0 became the ethernet card and eth1 became the firewire.
> To end the installation process it was necessary to change the file
> /etc/network/interfaces manually, typing eth0 where it contained eth1.

Known problem, with unfortunately no good known solution.

> - The HDs weren't automatically detected. They worked after loading the
> sd_mod and ata_piix modules.
> - The graphics card (an Intel integrated Graphics Media Accelerator 950)
> wasn't detected. It was necessary to run dpkg-reconfigure xserver-xorg
> to select the appropiate i810 module after installation.
> - The sound card (an integrated Intel HD Audio) wasn't detected. It was
> necessary to run alsaconf to make it work after installation.

May just be hardware is newer than the hardware database so it didn't
know what to use.

Len Sorensen

Reply to: