[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#350977: marked as done (Sarge install fails with Intel ICH74 Motherboard/SATA disks (no partitionable media))



Your message dated Thu, 2 Feb 2006 06:52:55 +0100
with message-id <20060202055255.GW5602@djedefre.onera>
and subject line Bug#350977: Sarge install fails with Intel ICH74 Motherboard/SATA disks (no partitionable media)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 2 Feb 2006 03:53:46 +0000
>From sigurd@silverstripe.com Wed Feb 01 19:53:46 2006
Return-path: <sigurd@silverstripe.com>
Received: from smtp3.mailprimer.com ([202.55.96.93])
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1F4VXV-0001BG-Kj
	for submit@bugs.debian.org; Wed, 01 Feb 2006 19:53:46 -0800
Received: from kristov.totallydigital.co.nz (202.68.92.242 [202.68.92.242])
	by smtp3.mailprimer.com; Thu, 2 Feb 2006 16:53:32 +1300 (NZDT),from [210.48.47.4] (helo=mescal)
	by kristov.totallydigital.co.nz with asmtp (Exim 3.36 #1 (Debian))
	id 1F4VHY-00035l-00
	for <submit@bugs.debian.org>; Thu, 02 Feb 2006 16:37:16 +1300
Message-ID: <mpn4.4011127.744421@smtp3.mailprimer.com>
Date: Thu, 2 Feb 2006 16:53:33 +1300 (NZDT)
From: Sigurd Magnuson <sigurd@silverstripe.com>
Reply-To: Sigurd Magnuson <sigurd@silverstripe.com>
To: <submit@bugs.debian.org>
Subject: Sarge install fails with Intel ICH74 Motherboard/SATA disks (no
 partitionable media)
Cc: 
MIME-Version: 1.0
Content-Type: multipart/alternative; 
	boundary="----=_Part_219553_23109986.1138852423765"
X-Mailer: mailPrimer v3.4.11
X-Orig-Mailer: Microsoft Outlook Express 6.00.2900.2180
mailPrimer: smtp3.mailprimer.com eid.4011127.11-1
X-Priority: 3
Thread-Index: bXBuNC40MDExMTI3Ljc0NDQyMUBzbXRw
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-1.8 required=4.0 tests=HAS_PACKAGE,HTML_30_40,
	HTML_MESSAGE autolearn=no version=2.60-bugs.debian.org_2005_01_02

------=_Part_219553_23109986.1138852423765
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Package: installation-reports
=20
 Boot method: CD
 Image version:
 http://cdimage.debian.org/debian-cd/3.1_r1/i386/iso-cd/debian-31r1a-i386-n=
etinst.iso
 Date: 2nd Feb 2006
 Machine: SuperMicro 5015P-TR 1U server with 4x 300GB SATA harddisks
 http://www.supermicro.com/products/system/1U/5015/SYS-5015P-TR.cfm
=20
 Processor: Pentium 4 D 3.0GHz dualcore
 Memory: 1GB
 Partitions: n/a (I wanted to RAID two disks, and have two non-RAIDle ones
 storing less impt data)
=20
 Output of lspci and lspci -n:
=20
 Base System Installation Checklist:
 [O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it
=20
 Initial boot worked: [O]
 Configure network HW: [E]
 existing e1000 driver failed with the onboard dual Intel=AE 82573V (Tekoa)
 PCI-e Gigabit cards
 Compiling my own worked like an absolute breeze. I suggest you update the
 e1000.o module to this authentic Intel revision;
 http://downloadfinder.intel.com/scripts-df-external/Detail_Desc.aspx?agr=
=3DY&Inst=3DYes&ProductID=3D2197&DwnldID=3D9180&strOSs=3D39&OSFullName=3DLi=
nux*%3C=3Deng
=20
 Config network: [O]
 Detect CD: [O]
 Load installer modules: [O]
 Detect hard drives: [E]
=20
 "No partitionable hardware found".
 Have tried with RAID turned on and off in BIOS, with SATA controller in
 compatible mode etc. It seems you need kernel 2.6.14, and installinging wi=
th
 "linux26" only yeilds 2.6.8, and thus fails. I'm not sure I see a way to
 proceed.
=20
 Partition hard drives: [ ]
 Create file systems: [ ]
 Mount partitions: [ ]
 Install base system: [ ]
 Install boot loader: [ ]
 Reboot: [ ]
=20
 Comments/Problems:
=20
 Is there some way I can install Sarge with this machine; the main road blo=
ck
 being the SATA disks? Is it easy, for example, to upgrade the kernel to so=
me
 more recent but use the (rather nice when used on other hardware) Sarge
 installer, so that, for example, setting up RAID 1 on two disks, and all
 manner of other tasks, is simplified?
=20
 Please note that I have had succes in getting this ISO to detect the
 hardidks as sda1...
 http://wiki.osuosl.org/display/LNX/Debian+on+Dell+Servers
 But I'd rather use the Sarge installer and not be stuck with a really old
 installation. I did give it a try, but then the e1000 driver needed
 recompilation, at at kernel 2.4.31 I wasn't sure how to compile it using m=
y
 existing working boxes. (its far beyond the apt-get kernel headers!)
=20
 I realise there is a set of information here: (but am clarifying if there =
is
 more recent updates)
 http://lists.us.dell.com/pipermail/linux-poweredge/2005-December/023650.ht=
ml
=20
 Thanks,
 Siggy,
 New Zealand=20
=20
=20
=20
=20
 Sigurd Magnusson
 SilverStripe
 sigurd@silverstripe.com
 +64 4 381 4482=20

------=_Part_219553_23109986.1138852423765
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd";>
<html>
<head>
<meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3Diso-8859-=
1">


<style>
<!--


 /* Font Definitions */
 @font-face
=09{font-family:Verdana, Arial, Helvetica, sans-serif;
=09}
@font-face
=09{font-family:"\\@Verdana";
=09}



BODY {

=09margin : 0px;
=09padding: 0px;

}


.footer, .footer TD{

=09font-family:Arial, Helvetica, sans-serif;
=09line-height: 11.0pt;
=09font-size : 9.0pt;
=09color : #666666;

}

.style1 {
=09color: #FF0000;
}
.style2 {
=09font-size: 12.0pt;
=09font-weight: bold;
}










 /* Style Definitions */
td, p.MsoNormal, li.MsoNormal, div.MsoNormal {
=09font-size:10.0pt;
=09line-height : 14.0pt;
=09font-family: Verdana, Arial, Helvetica, sans-serif;
=09mso-believe-normal-left:yes;
=09color :#333333;
=09}
=09
a:link, span.MsoHyperlink, a:visited, span.MsoHyperlinkFollowed, .footer TD=
 a:link, .footer TD a:visited{
=09color:#2F98D3;
=09text-decoration:none;
}
=09
a:hover, .footer TD a:hover, {
=09color : #53CAEB;
=09text-decoration:underline;=09
}

div.Section1
=09{page:Section1;}




-->
</style>



</head>

<body>





<table width=3D"100%"  border=3D"0" cellspacing=3D"0" cellpadding=3D"0">
  <tr>
    <td style=3D"border : 1px solid #d0cfce;"><table width=3D"100%"  border=
=3D"0" cellspacing=3D"0" cellpadding=3D"0" >
      <tr>
        <td colspan=3D"2" bgcolor=3D"#FCFBFB" ><table width=3D"100%"  borde=
r=3D"0" cellspacing=3D"0" cellpadding=3D"10">

            <tr>
              <td>Package: installation-reports<br>
<br>
Boot method: CD<br>
Image version:<br>
<a href=3D'http://cdimage.debian.org/debian-cd/3.1_r1/i386/iso-cd/debian-31=
r1a-i386-netinst.iso' target=3D'_blank'>http://cdimage.debian.org/debian-cd=
/3.1_r1/i386/iso-cd/debian-31r1a-i386-netinst.iso</a><br>
Date: 2nd Feb 2006<br>
Machine: SuperMicro 5015P-TR 1U server with 4x 300GB SATA harddisks<br>
<a href=3D'http://www.supermicro.com/products/system/1U/5015/SYS-5015P-TR.c=
fm' target=3D'_blank'>http://www.supermicro.com/products/system/1U/5015/SYS=
-5015P-TR.cfm</a><br>
<br>
Processor: Pentium 4 D 3.0GHz dualcore<br>
Memory: 1GB<br>
Partitions: n/a (I wanted to RAID two disks, and have two non-RAIDle ones<b=
r>
storing less impt data)<br>
<br>
Output of lspci and lspci -n:<br>
<br>
Base System Installation Checklist:<br>
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it<b=
r>
<br>
Initial boot worked:    [O]<br>
Configure network HW:   [E]<br>
 existing e1000 driver failed with the onboard  dual Intel=AE 82573V (Tekoa=
)<br>
PCI-e Gigabit cards<br>
Compiling my own worked like an absolute breeze. I suggest you update the<b=
r>
e1000.o module to this authentic Intel revision;<br>
<a href=3D'http://downloadfinder.intel.com/scripts-df-external/Detail_Desc.=
aspx?agr=3DY&Inst=3DYes&ProductID=3D2197&DwnldID=3D9180&strOSs=3D39&OSFullN=
ame=3DLinux*%3C=3Deng' target=3D'_blank'>http://downloadfinder.intel.com/sc=
ripts-df-external/Detail_Desc.aspx?agr=3DY&Inst=3DYes&ProductID=3D2197&Dwnl=
dID=3D9180&strOSs=3D39&OSFullName=3DLinux*%3C=3Deng</a><br>
<br>
Config network:         [O]<br>
Detect CD:              [O]<br>
Load installer modules: [O]<br>
Detect hard drives:     [E]<br>
<br>
"No partitionable hardware found".<br>
Have tried with RAID turned on and off in BIOS, with SATA controller in<br>
compatible mode etc. It seems you need kernel 2.6.14, and installinging wit=
h<br>
"linux26" only yeilds 2.6.8, and thus fails. I'm not sure I see a way to<br=
>
proceed.<br>
<br>
Partition hard drives:  [ ]<br>
Create file systems:    [ ]<br>
Mount partitions:       [ ]<br>
Install base system:    [ ]<br>
Install boot loader:    [ ]<br>
Reboot:                 [ ]<br>
<br>
Comments/Problems:<br>
<br>
Is there some way I can install Sarge with this machine; the main road bloc=
k<br>
being the SATA disks? Is it easy, for example, to upgrade the kernel to som=
e<br>
more recent but use the (rather nice when used on other hardware) Sarge<br>
installer, so that, for example, setting up RAID 1 on two disks, and all<br=
>
manner of other tasks, is simplified?<br>
<br>
Please note that I have had succes in getting this ISO to detect the<br>
hardidks as sda1...<br>
<a href=3D'http://wiki.osuosl.org/display/LNX/Debian+on+Dell+Servers' targe=
t=3D'_blank'>http://wiki.osuosl.org/display/LNX/Debian+on+Dell+Servers</a><=
br>
But I'd rather use the Sarge installer and not be stuck with a really old<b=
r>
installation. I did give it a try, but then the e1000 driver needed<br>
recompilation, at at kernel 2.4.31 I wasn't sure how to compile it using my=
<br>
existing working boxes. (its far beyond the apt-get kernel headers!)<br>
<br>
I realise there is a set of information here: (but am clarifying if there i=
s<br>
more recent updates)<br>
<a href=3D'http://lists.us.dell.com/pipermail/linux-poweredge/2005-December=
/023650.html' target=3D'_blank'>http://lists.us.dell.com/pipermail/linux-po=
weredge/2005-December/023650.html</a><br>
<br>
Thanks,<br>
Siggy,<br>
New Zealand <br>
<br>
<br>

               </td>
              </tr>
        </table></td>
      </tr>
      <tr>
        <td bgcolor=3D"#FCFBFB" style=3D"border-bottom: 1px solid #D0CFCE">=
<table width=3D"100%"  border=3D"0" cellspacing=3D"0" cellpadding=3D"10">
            <tr>
              <td valign=3D"middle" >
Sigurd Magnusson | Technical Director </p>
                </td>
              </tr>
        </table></td>
        <td width=3D"102" align=3D"right" valign=3D"bottom" bgcolor=3D"#FCF=
BFB" style=3D"border-bottom: 1px solid #D0CFCE" ><img src=3D"http://res.mai=
lprimer.com/emailhead/template/sslogo_top.gif" width=3D"102" height=3D"31">=
</td>
      </tr>
      <tr>
        <td height=3D"10" valign=3D"top"></td>
        <td width=3D"102" rowspan=3D"3" align=3D"right" valign=3D"top" ><im=
g src=3D"http://res.mailprimer.com/emailhead/template/sslogo-bottom.gif"; wi=
dth=3D"102" height=3D"66"></td>
      </tr>
      <tr>
        <td valign=3D"top"><table width=3D"100%"  border=3D"0" cellpadding=
=3D"10" cellspacing=3D"0">
          <tr>
            <td width=3D"160" valign=3D"top" class=3D"footer"><p class=3D"s=
tyle2">SilverStripe</p>
                <p>Level 4, 25a Marion Street<br>
        Wellington, New Zealand</p>
                <table width=3D"160" border=3D"0" cellspacing=3D"0" cellpad=
ding=3D"0">
                  <tr>
                    <td>Phone</td>
                    <td>+64 4 381 4482</td>
                  </tr>

                  <tr>
                    <td>Fax</td>
                    <td>+64 4  803 3347</td>
                  </tr>

                  <tr>
                    <td>Mobile</td>
                    <td>+64 21 421 208</td>
                  </tr>


                 =20

               </table></td>
            <td width=3D"1" valign=3D"top" style=3D"border-left : 1px solid=
 #D0CFCE">&nbsp;</td>
            <!-- clean.1 --><td valign=3D"top" class=3D"footer"><p class=3D=
"style2">SilverStripe Website Management</p>
                <p> SilverStripe gives you full control of your website. Fr=
om adding and modifying
pages on your website, to sending personalised email newsletters to thousan=
ds of
people, everything can be done quickly and easily by people without technic=
al
knowledge of the Internet.
                <p class=3D"style2">Find out more</p>
                <blockquote>
                  <div style=3D"padding-bottom : 4px;"></div>
                  <table width=3D"225"  border=3D"0" cellspacing=3D"0" cell=
padding=3D"0">
                    <tr>
                      <td width=3D"7" height=3D"16"><span class=3D"style1">=
&raquo;</span></td>
                      <td width=3D"218"><a href=3D"http://mail.mailprimer.c=
om/2671/17227659285847013/link1.do?mp&rd=3Dwww.silverstripe.com%3Flc=3Dt9.0=
&lc=3Dt9.0">Website Owners</a></td>
                    </tr>
                    <tr>
                      <td height=3D"16"><span class=3D"style1">&raquo;</spa=
n></td>
                      <td><a href=3D"http://mail.mailprimer.com/2671/172276=
59285847013/link1.do?mp&rd=3Dwww.silverstripe.com%3Flc=3Dt9.1&lc=3Dt9.1">We=
b Designers</a></td>
                    </tr>
                  </table>
                  </blockquote></td><!-- clean.1 -->
          </tr>
        </table></td>
        </tr>
      <tr>
        <td height=3D"10" valign=3D"top"></td>
        </tr>
    </table></td>
  </tr>
</table><!-- clean.2 --><table width=3D"100%" border=3D"0"><tr><td align=3D=
"right" style=3D"text-align:right;"><a href=3D"http://www.mailprimer.com"; t=
arget=3D"_blank"><img src=3D"http://mail.mailprimer.com/2671/17227659285847=
013/441/email1.do" style=3D"vertical-align:middle" alt=3D"0800 MAILPRIMER" =
width=3D"161" height=3D"17" border=3D"0"></a></td></tr></table><!-- clean.2=
 -->
<div> </div>
</body>
</html>

------=_Part_219553_23109986.1138852423765--


---------------------------------------
Received: (at 350977-done) by bugs.debian.org; 2 Feb 2006 05:53:39 +0000
>From bubulle@kheops.frmug.org Wed Feb 01 21:53:37 2006
Return-path: <bubulle@kheops.frmug.org>
Received: from perrier.eu.org ([81.56.227.253] helo=kheops.perrier.eu.org)
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1F4XPL-0005mA-FO
	for 350977-done@bugs.debian.org; Wed, 01 Feb 2006 21:53:32 -0800
Received: from localhost (localhost [127.0.0.1])
	by kheops.perrier.eu.org (Postfix) with ESMTP id 901C74F977;
	Thu,  2 Feb 2006 06:52:56 +0100 (CET)
Received: from kheops.perrier.eu.org ([127.0.0.1])
	by localhost (kheops [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id 25916-08; Thu, 2 Feb 2006 06:52:55 +0100 (CET)
Received: from mykerinos.kheops.frmug.org (mykerinos.kheops.frmug.org [192.168.1.3])
	by kheops.perrier.eu.org (Postfix) with ESMTP id D21A04F899;
	Thu,  2 Feb 2006 06:52:55 +0100 (CET)
Received: by mykerinos.kheops.frmug.org (Postfix, from userid 1000)
	id A119D40BDF5; Thu,  2 Feb 2006 06:52:55 +0100 (CET)
Date: Thu, 2 Feb 2006 06:52:55 +0100
From: Christian Perrier <bubulle@debian.org>
To: Sigurd Magnuson <sigurd@silverstripe.com>,
	350977-done@bugs.debian.org
Subject: Re: Bug#350977: Sarge install fails with Intel ICH74 Motherboard/SATA disks (no partitionable media)
Message-ID: <20060202055255.GW5602@djedefre.onera>
References: <mpn4.4011127.744421@smtp3.mailprimer.com>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <mpn4.4011127.744421@smtp3.mailprimer.com>
User-Agent: Mutt/1.5.11
X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at kheops.frmug.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

>  Is there some way I can install Sarge with this machine; the main road block
>  being the SATA disks? Is it easy, for example, to upgrade the kernel to some
>  more recent but use the (rather nice when used on other hardware) Sarge
>  installer, so that, for example, setting up RAID 1 on two disks, and all
>  manner of other tasks, is simplified?

(well known SATA issues with the sarge installer..this is why I close
the install report)

I suggest you try picking the etch installer beta 1 businesscard or
netboot image (NOT netinst) from
http://www.debian.org/devel/debian-installer and instruct it to
install "stable" by booting with:

"linux mirror/suite=stable"

Indeed, I'm not sure it will work..:-|

You unfortunately end in a difficult configuration wich unsupported
SATA hardware...SATA with sarge is not really well supported in many
cases...

But please let us know, in a separate report, whether this suggested
solution works. Again, there are great chances that it doesn't...



Reply to: