[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#348545: Install Report: ide controller confusion

Package: installation-reports

Boot method: CD
Image version: debian-testing-i386-netinst.iso, 1/16/2006, debian.org
Date: 1/16/2006, many times

Machine: ASUS K8N-E Mobo (nVidia nForce3 256Gb chipset)
Processor: AMD Sempron 3400+
Memory: 1GB
Partitions: Well, that's the problem...

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [E]
Create file systems:    [E]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


This motherboard has two onboard IDE controllers and two onboard SATA controllers. I have tried several different configurations of the harddrives and dvd-rom drive, all with the same basic failure. For example, in the simple configuration:
     1 HD on primary IDE           (jumpered to cable select)
     1 DVD burner on secondary IDE (jumpered to cable select)
the installer finds the following ide hosts
     Device                                         Major      Minor
     /dev/ide/host-1/bus1/target/lun0/cd               22          0
     /dev/ide/host-1/bus1/target/lun0/disk              3          0
     /dev/ide/host0/bus1/target1/lun0/part              3          1
     /dev/ide/host2/bus1/target2/lun0/part              3          2
     /dev/ide/host4/bus1/target5/lun0/part              3          5
Yep, that is host-1, as in host-negative-one, and yep, the partitions of that disk are showing up on other ide hosts. That seems odd already.

When I partition the disk (w/o LVM, automatically setup as one big partition), it seems to work (on /dev/ide/host-1/bus1/target/lun0/disk0). When it attempts to create the ext3 filesystem on the new partition, it gets to 100%, and then reports that filesystem creation failed. If I look on console 4, I see several messages:

partman: tune2fs: No such file or directory while trying to open /dev/ide/host-1/bus1/target/lun0/part1
partman: Couldn't find valid filesystem superblock.
partman: mke2fs 1.39-WIP (31-Dec-2005)
partman: Could not stat /dev/ide/host-1/bus1/target/lun0/part1 - No such file or directory
partman: The device apparently does not exist; did you specify correctly?

Also, at this point, /dev/ide/host2 is gone. This all occurs even if I disable the SATA controllers in the bios.

If I try the install24 option, with or without SATA enabled in the BIOS, then I get a much saner set of ide devices:
But install24 fails with the installer message box
      Error while running 'modprobe -v forcedeth'

I've also tried the 3.1r1 network installer. Both the 2.4 and 2.6 kernels see the good ide configuration, but fail to detect my network card.

I just tried the etch beta 1 installer, and everything works.

I hope this information helps you track down this odd bug. Thanks for all your hard work.


Reply to: