[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#342706: D-I - Minor buildd problems



Package: libgtk+2.0-directfb0
Version: 2.0.9.2-12
Severity: serious

This from a thread on d-release.

Alastair, could you please look into this?
As it is keeping cdebconf from building on 2 arches, it's pretty important.

On Friday 09 December 2005 17:03, Steve Langasek wrote:
> On Fri, Dec 09, 2005 at 01:17:42PM +0100, Frans Pop wrote:
> > There are several packages relevant for the installer that have what
> > looks like minor problems keeping them from being built on some
> > arches.

> > - cdebconf (0.91)
> >   Failed on alpha and ia64 with strange build dep error; a simple
> > retry may fix this.
>
> No, this is someone trying to be clever and hard-coding a dependency on
> libc6 into libgtk+2.0-directfb0.  The correct dependency on alpha and
> ia64 is libc6.1.  (I have no idea what the alternative on "| libc" is
> supposed to do; *nothing* provides "libc" on alpha, and even if it did,
> it'd be bloody worthless as a dependency.  We have sonames in our lib
> package names for a reason!)

Attachment: pgpaBft9utpBu.pgp
Description: PGP signature


Reply to: