[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287409: marked as done (suggest renaming "desktop" partitioning scheme since it's not always appropriate for desktop installs)

Your message dated Wed, 07 Dec 2005 19:02:05 -0800
with message-id <E1EkC2n-0002i4-Sf@spohr.debian.org>
and subject line Bug#287409: fixed in partman-auto 46
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 27 Dec 2004 05:02:02 +0000
>From joey@kitenet.net Sun Dec 26 21:02:02 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Cin18-0008Kr-00; Sun, 26 Dec 2004 21:02:02 -0800
Received: from dragon.kitenet.net (unknown [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 4295417DF7;
	Mon, 27 Dec 2004 05:01:59 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id BA6AF6E0C2; Mon, 27 Dec 2004 00:03:48 -0500 (EST)
Date: Mon, 27 Dec 2004 00:03:48 -0500
From: Joey Hess <joeyh@debian.org>
To: submit@bugs.debian.org
Cc: anna@kitenet.net
Subject: rc2 netinst install on hp pavilion ze4900 laptop
Message-ID: <20041227050347.GA8420@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="k1lZvvs/B4yU6o8G"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: installation-reports

Debian-installer-version: rc2 netinst

Machine: hp pavilion ze4900
Processor: 686
Memory: 256 mb
Root Device: ~30 gb ide
uname -a:
Linux grebe 2.6.8-1-686 #1 Thu Nov 25 04:34:30 UTC 2004 i686 GNU/Linux

Output of lspci and lspci -n:

0000:00:00.0 0600: 8086:3580 (rev 02)
0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 0880: 8086:3584 (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Contr=
ol Registers (rev 02)
0000:00:00.3 0880: 8086:3585 (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Pr=
ocess Registers (rev 02)
0000:00:02.0 0300: 8086:3582 (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated =
Graphics Device (rev 02)
0000:00:02.1 0380: 8086:3582 (rev 02)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphic=
s Device (rev 02)
0000:00:1d.0 0c03: 8086:24c2 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-=
M) USB UHCI Controller #1 (rev 03)
0000:00:1d.1 0c03: 8086:24c4 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-=
M) USB UHCI Controller #2 (rev 03)
0000:00:1d.2 0c03: 8086:24c7 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-=
M) USB UHCI Controller #3 (rev 03)
0000:00:1d.7 0c03: 8086:24cd (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 =
EHCI Controller (rev 03)
0000:00:1e.0 0604: 8086:2448 (rev 83)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 83)
0000:00:1f.0 0601: 8086:24cc (rev 03)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev=
0000:00:1f.1 0101: 8086:24ca (rev 03)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage C=
ontroller (rev 03)
0000:00:1f.3 0c05: 8086:24c3 (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus =
Controller (rev 03)
0000:00:1f.5 0401: 8086:24c5 (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4=
/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 0703: 8086:24c6 (rev 03)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 =
Modem Controller (rev 03)
0000:02:00.0 0200: 10ec:8139 (rev 10)
0000:02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/=
8139C/8139C+ (rev 10)
0000:02:05.0 0607: 104c:ac50 (rev 02)
0000:02:05.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Cont=
roller (rev 02)
0000:02:06.0 0280: 14e4:4320 (rev 03)
0000:02:06.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wir=
eless LAN Controller (rev 03)

Base System Installation Checklist:
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


User install

I let the laptop's owner install it. She's a longtime linux user, but
has never done an install before. Some UI notes:

 - If the user doesn't know what partitioning is, even partman-auto's
   initial screen is hard to understand. Simply explainsing that it's how
   the disk is divided up between OS's would have helped.
 - She couldn't figure out which of the first 2 partition recipies to use
   (one partiton and desktop). She knew she wanted to use her system for a
   desktop so thought maybe the second. I had a hard time explaining why
   one ig partiton might be appropriate for a desktop install.
 - The crash explained below was handled by me, she took over again at
 - She had to be told to use space to pick tasks in tasksel.=20
   She wasn't sure if she should install the mail server task -- she knew
   that she wanted a basic mail server. I had to explain that this task is
   for larger mail servers and that she'd get a basic one w/o it.
 - exim config was uncertian, but she muddled thru.
 - I was out of the room for X config, and she gave up on the fun screen
   where it asks (uselessly on i386) for a PCI ID of the video card.
 - She also didn't pick the right X driver, and apparently X didn't detect =
   she should use i810 instead of the default vesa driver. This resulted in
   bad refresh rates and flicker.
 - She didn't notice the program that was named after her. :-)
 - She read _everything_ (except syslinux help screens), and paid especial
   attention to the partman confirm screen and grub screen, just as we'd wa=
   an ideal user to do. (And just as we don't. ;-)
 - She wondered why passwd config wanted her full name. This is reasonable.
   We should probably mention how that info is used.


The wireless on this laptop is a broadcom and of course does not work in
the installer. Ethernet worked ok.

I later got wireless working by using ndiswrapper.

Sound crash

At reboot we got a system oops after it loaded the i810_audio module.
Annoyingly, this oops did not stop the module loading, and though the
boot later hung, it wasn't enough to trigger discover's crash detection. I
added i810_audio to discover blacklist to get around this .. only to have
to boot emergency a second time to add it to the hotplug blacklist. Argh!

Here's the oops:

Loading i810_audio module.

Intel 810 + AC97 Audio, version 1.01, 04:39:21 Nov 25 2004
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:1f.5 to 64
i810: Intel ICH4 found at IO 0x18c0 and 0x1c00, MEM 0xe0100c00 and 0xe01008=
00, IRQ 5
i810: Intel ICH4 mmio at 0xcea7ec00 and 0xceaf8800
i810_audio: Primary codec has ID 0
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 0
ac97_codec: AC97 Modem codec, id: CXT48 (Unknown)
i810_audio: codec 0 is a softmodem - skipping.
Unable to handle kernel NULL pointer dereference at virtual address 00000024
 printing eip:
*pde =3D 00000000
Oops: 0000 [#1]
Modules linked in: i810_audio ac97_codec ndiswrapper i830 ipv6 ds parport_p=
c lp parport button ac 8139cp snd_ac97_codec snd_pcm snd_timer snd_page_all=
oc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore hw_ran=
dom pciehp shpchp pci_hotplug ehci_hcd intel_agp agpgart joydev psmouse pcs=
pkr rtc evdev mousedev tsdev usbhid af_packet uhci_hcd 8139too mii crc32 ye=
nta_socket pcmcia_core capability commoncap battery fan thermal processor u=
sbcore ide_cd cdrom isofs ext2 ext3 jbd mbcache ide_generic ide_disk piix i=
de_core unix font vesafb cfbcopyarea cfbimgblt cfbfillrect
CPU:    0
EIP:    0060:[<cee69172>]    Tainted: P =20
EFLAGS: 00010246   (2.6.8-1-686)=20
EIP is at i810_set_spdif_output+0x22/0x160 [i810_audio]
eax: ffffffff   ebx: 00000000   ecx: cd962c00   edx: cd962c00
esi: 00000000   edi: 00000000   ebp: cd0e8840   esp: c640be30
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 14022, threadinfo=3Dc640a000 task=3Dc214a640)
Stack: 00004a06 ffffffce c011c7f4 00000000 cd0e8840 00000000 cd0e88d8 00000=
       cee6df9f cd0e8840 ffffffff 00000000 cee6f740 c640be7c c1208580 00000=
       cd962c00 cee6ddb0 cd0e8870 cd962c00 00000000 00000001 00000000 00000=
Call Trace:
 [<c011c7f4>] release_console_sem+0xc4/0xd0
 [<cee6df9f>] i810_configure_clocking+0xbf/0x4c0 [i810_audio]
 [<cee6ddb0>] i810_ac97_init+0x4a0/0x5d0 [i810_audio]
 [<cee6e84f>] i810_probe+0x4af/0x690 [i810_audio]
 [<c01aec42>] pci_device_probe_static+0x52/0x70
 [<c01aec9c>] __pci_device_probe+0x3c/0x50
 [<c01aecdc>] pci_device_probe+0x2c/0x50
 [<c01f67cf>] bus_match+0x3f/0x70
 [<c01f68fc>] driver_attach+0x5c/0xa0
 [<c01f6e21>] bus_add_driver+0x91/0xb0
 [<c01f73cf>] driver_register+0x2f/0x40
 [<c011c681>] printk+0x111/0x170
 [<c01aef5c>] pci_register_driver+0x5c/0x90
 [<cea7c01b>] i810_init_module+0x1b/0x99 [i810_audio]
 [<c0133030>] sys_init_module+0x100/0x210
 [<c0105fe9>] sysenter_past_esp+0x52/0x71
Code: 8b 43 24 8b 48 08 85 c9 75 27 0f b7 82 16 02 00 00 83 e0 fb=20

After the oops it went on a bit longer and then hung somewhere in hotplug,
did not respond to ctrl-c, but typing and scrolling worked. I got similar
oopes and crashes in 2.4 and 2.6; above oops is from 2.6.

I think that this is possibly aggravated by discover/hotplug wanting to
load two sound drivers, because in addition to i810_audio, it or=20
hotplug loaded snd_intel8x0 (alsa, right?). Here's how lsmod ended up
looking after I blacklisted i810_audio:

Module                  Size  Used by
snd_intel8x0           36460  0=20
snd_ac97_codec         70020  1 snd_intel8x0
snd_pcm_oss            55048  0=20
snd_mixer_oss          20096  1 snd_pcm_oss
snd_pcm                98728  2 snd_intel8x0,snd_pcm_oss
snd_timer              25668  1 snd_pcm
snd_page_alloc         11752  2 snd_intel8x0,snd_pcm
gameport                4704  1 snd_intel8x0
snd_mpu401_uart         7968  1 snd_intel8x0
snd_rawmidi            25156  1 snd_mpu401_uart
snd_seq_device          8200  1 snd_rawmidi
snd                    57156  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd=
soundcore              10336  1 snd

With alsa and 2.6, the sound works (I ran alsacfg, not sure if it worked
before that.) The laptop's sound buttons don't seem to do anything.


Suspend doesn't work. No big suprise there.

I was suprised to see that the acpi fan and thermal modules were not loaded
on the installed system. This seems to be an oversight in rootskel, it
loads the modules in the installer, but neglects to register-module them.

If acpid had been installed, I think it would have taken care of loading
all those modules. And it's needed for the gnome battery monitor anyway. We
need a laptop task! However, I think that even with that, unconditionally
register-moduleing fan and thermal is good from a belt and suspenders POV.


rc2 netinst has some kinda old stuff, and I noticed that one thing we don't
do is apt-get upgrade the installed system. So tasksel installs all new
stuff from the mirror, but the base system can have some kinda old
packages. From a security POV, an upgrade as part of the install would be

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Received: (at 287409-close) by bugs.debian.org; 8 Dec 2005 03:21:32 +0000
>From katie@ftp-master.debian.org Wed Dec 07 19:21:32 2005
Return-path: <katie@ftp-master.debian.org>
Received: from katie by spohr.debian.org with local (Exim 4.50)
	id 1EkC2n-0002i4-Sf; Wed, 07 Dec 2005 19:02:05 -0800
From: Joey Hess <joeyh@debian.org>
To: 287409-close@bugs.debian.org
X-Katie: $Revision: 1.60 $
Subject: Bug#287409: fixed in partman-auto 46
Message-Id: <E1EkC2n-0002i4-Sf@spohr.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Wed, 07 Dec 2005 19:02:05 -0800
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 4

Source: partman-auto
Source-Version: 46

We believe that the bug you reported is fixed in the latest version of
partman-auto, which is due to be installed in the Debian FTP archive:

  to pool/main/p/partman-auto/partman-auto_46.dsc
  to pool/main/p/partman-auto/partman-auto_46.tar.gz
  to pool/main/p/partman-auto/partman-auto_46_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 287409@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated partman-auto package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed,  7 Dec 2005 21:55:20 -0500
Source: partman-auto
Binary: partman-auto
Architecture: source i386
Version: 46
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 partman-auto - Automatically partition storage devices (partman) (udeb)
Closes: 261182 287409 288884 289419 328514 330079
 partman-auto (46) unstable; urgency=low
   [ Joey Hess ]
   * Renamed multi_user scheme to just "multi" as in multiple partitions.
     There are more uses for this scheme than multi user systems.
   * Switch package to arch all and only include recipes for the given
     architecture and any subarches in each package.
   * Rules file cleanups.
   * Control file cleanups.
   * Change descriptions of home and multi recipes to just list the partitions
     that are included. Closes: #287409, #288884
   * Increase minimal size of / partition in home recipe to 500 mb.
     Closes: #289419, #330079
   * Double the weight of the root partition in the multi scheme from 400 to
     800. This should increase the size allocated on reasonable size disks
     from the previous 250 mb to something slightly more reasonable.
     Closes: #328514
   [ Steve Langasek ]
   * Add a smalldisk recipe for alpha, so that systems with little disk space
     can use a single ext2 partition for the whole install (closes: #261182).
   [ Colin Watson ]
   * Remove duplicated chrp_rs6k recipes and install a symlink instead.
   [ Fabio M. Di Nitto ]
   * Start implementing bits required to avoid code duplication with
     partman-auto-lvm as per discussion on debian-boot mailing list.
     (See http://lists.debian.org/debian-boot/2005/10/msg00842.html)
   * Add lvmok{ } to recipes as per discussion on debian-boot mailing list.
       - nobody objected to a tag/properties/flag name or proposed something
         different. It is clearly ok to rename it if it doesn't fit.
       - swap will stay out of LVM for now. In some cases it is known to break
         suspend/resume. It seems not all kernels are able to resume from it.
       - porters will have to adjust their recipes. I could only test
         i386/amd64 (via recipes) and powerpc-powermac_newworld (via
   * Move common code into auto-shared.sh shelllib and create 3 functions:
     wipe_disk, create_primary_partitions (see comments in the file) and
   * Install auto-shared.sh in /lib/partman (chages debian/rules)
   * Make perform_recipe and autopartition use auto-shared.sh.
   * Make create_partitions set a var for all the devices that will be marked
     as pv. This is actually only used by partman-auto-lvm, but it is generic
     enough that could be used later on for other tasks.
     NOTES: the above changes have been tested on i386/amd64/ppc and there is
     no known breakage. The code is only moved around and none of the actual
     recipes use method{ lvm } used by partman-auto-lvm to mark partitions as
     pv volumes.
 98ab1c59d8ed20964b2d42e8494cb80b 632 debian-installer standard partman-auto_46.dsc
 2dc26285aead0553058a97ba4082f0f1 67526 debian-installer standard partman-auto_46.tar.gz
 9f2e3f2cee6ed8d30bc94d89ea800b00 44228 debian-installer standard partman-auto_46_i386.udeb
Package-Type: udeb

Version: GnuPG v1.4.2 (GNU/Linux)


Reply to: