[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Status of d-i kernel transition for 2.6.14

(CC'ing port mailing lists where the port does not have 2.6 support in d-i)

An update of the table of kernel versions.

General comments:
- CD images still use 2.6.12 as Etch is installed
- only x86 and sparc64 fully switched to 2.6.14 for sid_d-i
- powerpc and amd64 have uploaded new udebs, but not yet updated d-i config
- hppa should update kernel udebs to 2.6.14
- arm, mips, mipsel have initial (now outdated) 2.6 kernel udeb packaging
  in the d-i SVN repository, but never yet uploaded
- sparc32 was badly supported in 2.6.12 and thus does not have a 2.6 installer,
  possibly this will be implemented for a later version

The 2nd and 3rd columns in this table also show that a lot of arches do not
currently have 2.6 kernel udebs in the archive or at least do not have d-i
images that boot with a 2.6 kernel.
This situation is highly undesirable as 2.6 _is_ the preferred kernel for
most architectures when running unstable and will also be the main kernel
version for Etch.

The D-I Etch beta2 release is provisionally planned for the 2nd half of
January and should have the 2.6.15 kernel that is expected to be released
within the next few weeks.

Porters should really start implementing support for 2.6 in d-i for their
architecture in order to be ready for Etch and allow sufficient time for
testing and ironing out possible issues. Support for 2.6 should probably
be implemented in time for the D-I Etch beta3 release (at the very latest!).

Help in this effort is of course available from the rest of the d-i team
where needed.

arch     udeb                build/config      base-installer  debian-cd
-------- ------------------- ----------------- --------------- ------------
i386     2.6.14-2/2.4.27-2   2.6.14-2/2.4.27-2 2.6/2.4.27-2    2.6/2.4.27-2
alpha    2.4.27-2/(2.6.12-1) 2.4.27-2                          2.4.27-2
amd64    2.6.14-3            2.6.12-1          2.6             2.6
arm      2.4.27              2.4.27                            2.4.27
hppa     2.6.12-1            2.6.12-1          2.6.12-1/2.4.27 2.6
ia64 *)  2.6.12-1/2.4.27-2   2.6.12-1/2.4.27-2 2.6/2.4.27-2    2.6/2.4.27-2
m68k     2.4.27/(2.6.12-1)   2.4.27                            2.4.27
  mac    2.2.25              2.2.25                            2.2.25
mips     2.4.27              2.4.27                            2.4.27
mipsel   2.4.27              2.4.27                            2.4.27
powerpc  2.6.14-2/2.4.27     2.6.12-1/2.4.27                   2.6/2.4.27
s390     2.4.27-2            2.4.27-2          2.4.27-2        N/A
sparc32  2.4.27-2            2.4.27-2                          2.4.27-2
sparc64  2.6.14-2/2.4.27-2   2.6.14-2/2.4.27-2                 2.6/2.4.27-2

[1] 2.6.14-2 does not boot on IA64, waiting for 2.6.15

A new 2.4.27 kernel for x86 has just been accepted into unstable so 2.4 kernel
udebs will also need updating soon.

Frans Pop

Attachment: pgpbnv13zgZfi.pgp
Description: PGP signature

Reply to: