[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#341597: [ppc,d-i-gtk] installation report on b&w G3

Package: installation-reports

Boot method: miniiso with graphical installer daily build from Sven Luther
Image version: http://people.debian.org/~luther/d-i/gtkdi/images/2005-12-01/powerpc/gtk-miniiso/mini.iso
Date: 2005-12-01 

Machine: Apple PowerMac G3 (Blue&White)
Processor: G3, 400 MHz
Memory: 192 MB
Partitions: <df -Tl will do; the raw partition table is preferred>

Output of cat /proc/cpuinfo:
processor	: 0
cpu		: 740/750
temperature 	: 32-37 C (uncalibrated)
clock		: 400MHz
revision	: 2.2 (pvr 0008 0202)
bogomips	: 794.62
machine		: PowerMac1,1
motherboard	: PowerMac1,1 MacRISC Power Macintosh
detected as	: 66 (Blue&White G3)
pmac flags	: 00000000
L2 cache	: 1024K unified
memory		: 192MB
pmac-generation	: NewWorld

Output of lspci
0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 PCI bridge: Digital Equipment Corporation DECchip 21154 (rev 02)
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128 RE/SG
0000:01:00.0 FireWire (IEEE 1394): Texas Instruments PCILynx/PCILynx2 IEEE 1394 Link Layer Controller (rev 02)
0000:01:01.0 IDE interface: Silicon Image, Inc. PCI0646 (rev 07)
0000:01:03.0 SCSI storage controller: Adaptec AHA-7850 (rev 03)
0000:01:05.0 ff00: Apple Computer Inc. Paddington Mac I/O
0000:01:06.0 USB Controller: OPTi Inc. 82C861 (rev 10)

Output of lspci -n
0000:00:00.0 0600: 1057:0002 (rev 40)
0000:00:0d.0 0604: 1011:0026 (rev 02)
0000:00:10.0 0300: 1002:5245
0000:01:00.0 0c00: 104c:8000 (rev 02)
0000:01:01.0 0101: 1095:0646 (rev 07)
0000:01:03.0 0100: 9004:5078 (rev 03)
0000:01:05.0 ff00: 106b:0017
0000:01:06.0 0c03: 1045:c861 (rev 10)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


I booted the machine from cdrom and all seemed ok until it should start
X. Then it crashed showing a blue screen with a small garbled image in
the middle. No keyboard interaction anymore.

The next try was with "expert video=ofonly". It did not crash this time,
but it failed to start X too. Instead it tried to restart X endlessly,
showing the error message to short to read it. A colleague of mine was
able to take a picture in just the right moment, so that we could read:
(!) DirectFB/Core/NM: Panning Display failed!
    --> Invalid argument
(!) [ 3163:   0.000] --> Caught signal 11 (at 0x303a9000, invalid permissions)

I could switch to the next console and cat /var/log/syslog were I read 

init: Starting pid 3064, console /dev/vc/1: /sbin/debian-installer
init: Process /sbin/debian-installer (pid 3064) exited. Scheduling it for restart.

The pictures we took are available on the net:

The picture with the crashed X after normal start and the whole computer:

The X-Error message after video=ofonly:

The installation with the normal (non-graphical) mini-iso went fine, we
could initialise the network and X starts without problems.

Plese tell me how I can help to debug this issue. I will retry the
graphical installer from time to time and follow up on this bug-report.



Attachment: signature.asc
Description: Digital signature

Reply to: