[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I2O detection problem for 2.6 kernels



On Friday 25 November 2005 22:07, Lennart Sorensen wrote:
> i386 has dpt_i2o, while amd64 being 64bit does not.  Does discover know
> that?  The driver apparently isn't 64bit clean and is flagged in the
> kernel config as such.  So while dpt_i2o is preferable, it is not an
> option on amd64.

Thanks for that info.

Looks like discover does have an option for architecture specific 
overrides, but there are currently none for amd64. Not sure though as I'm 
not really familiar with discover internals.

If this override is set, it will mean that amd64 porters will need to keep 
and eye out and request for it to be removed should the driver get fixed 
in the kernel.

> This does seem like an installer problem.

However, I'm not sure if it's worth doing this as the i2o_block does not 
seem to function properly given the problems with partitioning mentioned 
a bit later in David's mail (which is what I was really refering to with 
my comment).
So IMO there still is a kernel problem that prevents installation...

Cheers,
FJP

P.S. In order to be able to properly track this issue an installation 
report [1] should be filed with all the relevant info from the mails so 
far. David: could you do that please?
Please also try to get the lspci info.

[1] http://d-i.alioth.debian.org/manual/en.i386/ch05s03.html#submit-bug

Attachment: pgpPPi8tuJEGC.pgp
Description: PGP signature


Reply to: