[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem building images for GTK frontend

I'm running into a dependency problem building the GTK frontend from the 

The following packages have unmet dependencies:
  libdirectfb-0.9-22-udeb: Depends: libfreetype6 (>= 2.1.5-1)
                           Depends: libpng12-0 (>= 1.2.8rel)
                           Depends: zlib1g (>= 1:1.2.1)
  libfreetype6-udeb: Depends: zlib1g (>= 1:1.2.1)
  libpango1.0-udeb: Depends: libfontconfig1 (>= 2.3.0)
                    Depends: libfreetype6 (>= 2.1.5-1)
                    Depends: zlib1g (>= 1:1.2.1)

However, all needed udebs are listed as "Need to download".
The problem may be in the versioned dependencies on _normal_ packages and 
the fact that these are covered by udebs having "Provides:".

The strange thing is that the only solution seems to be to have the 
_calling_ udebs in localudebs.
Adding libdirectfb-0.9-22-udeb, libfreetype6-udeb and libpango1.0-udeb 
there results in the following:

The following packages have unmet dependencies:
  fontconfig-udeb: Depends: libfreetype6-udeb but it is not going to be 
  libgtk+2.0-directfb0-udeb: Depends: libdirectfb-0.9-22-udeb but it is 
not going to be installed

Adding these _calling_ udebs to localudebs results in a working build (if 
localudebs has a Packages file and is in sources.list.udeb).

Any ideas how to get around this?


Attachment: pgpBLaEuaJA4Q.pgp
Description: PGP signature

Reply to: