[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installer hangs while booting

Hans-Thomas Götz wrote:
> Hi,
> i try to install debian 3.1 on one of my machines, but the installer
> seems to fail somehow - it stops responding and nothing is happening for
> more than 10 Minutes ( i even waited more than 30 Minutes sometimes ).
< ... >
> When i boot from cdrom/dvdrom i just press return to accept the default
> linux 2.4 Kernel. I get a menu to select the language ( english ), a
> second menu to select the region ( germany ) and at last a menu to
> select the keymap to use ( german ). After that the hardware-detection
> starts. It displays the message: "Detecting hardware to find CD-ROM
> drives" and below the progress-bar (5% ) there is the message "Loading
> module 'aic7xxx' for 'Adaptec AHA-2940U2/U2W / 7890/7891' ..." There it
> stops and nothing is happening for more than half a hour. The hdd led is
> burning constantly, but the DVD-ROM is doing nothing at all. I tried to
> use the 2.6 kernel but it fails even befor i reach the first menu with
> the last message something like "net: protocol family 2" or somthing
> like that. I tried to use several installer options to disable ide-dma
> or acpi or apic etc. but nothing works.
> When i use expert-made i make it to the menues. The Problem is that most
> of the time the installer stops responding while i am browsing the
> menus. This happens in more than 95% of the time; in fact i only managed
> to start cdrom-detection once and there it hangs at the same step as
> before: ( 14% ) with the message: "Loading module 'aic7xxx' for 'Adaptec
> AHA-2940U2/U2W / 7890/7891' ...". Ok, i managed to deselect scsi-support
> and every chipset-driver except the PII4X4 ide. Now, CD-Rom detection
> stops with the following message:
> "Loading module 'ide-cd' for 'Linux ATAPI CD-ROM' ..."
> I removed the network- and the ISDN-card, but nothing changed. I
> replaced the IBM-HDD with a WD 1000BB but the same problem again.
> Just to see if it works, i tried to boot debian-Knoppix 3.4 and basicly
> got the same problem.
> My hardware:
> PIII 800
> Asus P2B-S motherboard with Adaptec AHA 2940U2W SCSI-controller on board
> ( Intel 440BX-chipset )
> 256 MB ram
> VGA: Elsa Gladiac GeForce 2 GTS graphics card or ATI rage pro 128
> PCI-cards:
> Realtec 8139 100MBit-network adapter
> Fritz ISDN-card
> ISA-cards:
> Soundblaster AWE 32
> IDE:
> primary master: WD 1000BB ( was at first: IBM DTLA 307045 )
> secondary master Toshiba DVD-ROM SD-M1222
> Thanks for any help in advance!
> Thomas
Hi Thomas

Sorry for the late answer.

This looks like a hardware problem to me.
Could you run a memory (= RAM) test on this machine?
Could you also exchange the IDE cables?
Also changing jumper settings from 'autoselect' to 'master' or 'only drive'
gave me once some improvements.

While in expert mode I would suggest, to load 'ide-cd' before the chipset
driver. Sometimes they block each other when loaded in wrong sequence.


Reply to: