[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#323440: installation-reports

> On Tuesday 16 August 2005 21:57, Christian Jordan wrote:
> > Reboot:			[E] - kernel panic (pivot_root: no such file or
> > directory; /sbin/init: 432: cannot open dev/console: No such file;
> > Kernel panic: Attempted to kill init!
> This is to be expected at the moment as a 2.6.8 kernel is installed for
> the new system (as 2.6.12 is not yet available in testing).
> You can solve this by switching to VT2 after the base-installation step
> and doing the following:
> - chroot /target
> - wget the correct 2.6.12 linux-image package for your system from a
>   debian mirror
> - dpkg -i that package
> - exit the chroot
> - resume installation

Thanks for answering! I tried something like that already - but there were
also networking issues (refer to Bug#324011 - sorry for not using the same
bug number, I'm not really experienced in giving bug reports and

Short summary on my installation experience:

The main trouble is, that the sata_uli.ko is available in the installer
(but still requires special treatment to load it - as mentioned), but
not in the kernelpackage 2.6.8 (which is used by amd64-testing, as you
already noted) and therefore also not in the initrd.img --> kernel panic
at boot.

The debian installer seems to work fine - after I included the missing
module using the rescue-mode (via usb_storage, since the network card is
not recognized), the system booted up and the installer finished its work
(at least tried to in some aspects, since there was no network).

Now my next step is to fix the network support; but that's not an
installer issue (anyway, maybe you could include the bcm57xx-module which
is suggested by broadcom).

[Off topic:]
In meantime I have a running debian system (now running a
with built-in sata and networking support) with graphics, office... - I
did not test sound so far.
Because of the network "failure" during install there was a
misconfiguration of tasksel/aptitude (came up that nothing was installed,
and every time I tried to change the settings - e.g. if I wanted to
install a KDE... instead of the base system - it did nothing and just
ignored my input). So I had to install everything manually with apt.

Best regards,

Reply to: