[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#322240: Silicon Image SiI 3112 SATALink

Package: installation-reports

Debian-installer-version: Debian 3.1 sarge netinst 2005-06-07
uname -a: Linux (none) 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005 i686 unknown 
Date: 2005-08-09 12:00 PST
Method: netinst from CD

Machine: Desktop PC
Processor: Athlon XP 2400+
Memory: 768 MB
Root Device: SATA 200 GB Seagate ST3200826AS
Root Size/partition table:
Minor    Start       End     Type      Filesystem  Flags
1          0.031   5718.449  primary   ntfs
2       5718.450   6675.446  primary   ext3 (unused)
3       6675.447  18120.190  primary   ext3 (/)
4      18120.190 190779.719  extended
5      18120.221  56266.721  logical   ext3 (/home)
6      56266.752 189783.500  logical               lvm (/var)
7     189783.532 190779.719  logical   linux-swap
Output of lspci and lspci -n:
# lspci
0000:00:00.0 Host bridge: nVidia Corporation nForce CPU bridge (rev b2)
0000:00:00.1 RAM memory: nVidia Corporation nForce 220/420 Memory
Controller (rev b2)
0000:00:00.2 RAM memory: nVidia Corporation nForce 220/420 Memory
Controller (rev b2)
0000:00:00.3 RAM memory: nVidia Corporation: Unknown device 01aa (rev b2)
0000:00:01.0 ISA bridge: nVidia Corporation nForce ISA Bridge (rev c3)
0000:00:01.1 SMBus: nVidia Corporation nForce PCI System Management (rev c1)
0000:00:02.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
0000:00:03.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
0000:00:04.0 Ethernet controller: nVidia Corporation nForce Ethernet
Controller (rev c2)
0000:00:05.0 Multimedia audio controller: nVidia Corporation: Unknown
device 01b0 (rev c2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce
Audio (rev c2)
0000:00:08.0 PCI bridge: nVidia Corporation nForce PCI-to-PCI bridge (rev c2)
0000:00:09.0 IDE interface: nVidia Corporation nForce IDE (rev c3)
0000:00:1e.0 PCI bridge: nVidia Corporation nForce AGP to PCI Bridge (rev b2)
0000:01:06.0 Ethernet controller: Accton Technology Corporation
SMC2-1211TX (rev 10)
0000:01:07.0 Multimedia video controller: Internext Compression Inc
iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
0000:01:08.0 Unknown mass storage controller: Silicon Image, Inc.
(formerly CMD Technology Inc) SiI 3112 [SATALink/SATARaid] Serial ATA
Controller (rev 02)
0000:02:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550
AGP (rev 01)
# lspci -n
0000:00:00.0 0600: 10de:01a4 (rev b2)
0000:00:00.1 0500: 10de:01ac (rev b2)
0000:00:00.2 0500: 10de:01ad (rev b2)
0000:00:00.3 0500: 10de:01aa (rev b2)
0000:00:01.0 0601: 10de:01b2 (rev c3)
0000:00:01.1 0c05: 10de:01b4 (rev c1)
0000:00:02.0 0c03: 10de:01c2 (rev c3)
0000:00:03.0 0c03: 10de:01c2 (rev c3)
0000:00:04.0 0200: 10de:01c3 (rev c2)
0000:00:05.0 0401: 10de:01b0 (rev c2)
0000:00:06.0 0401: 10de:01b1 (rev c2)
0000:00:08.0 0604: 10de:01b8 (rev c2)
0000:00:09.0 0101: 10de:01bc (rev c3)
0000:00:1e.0 0604: 10de:01b7 (rev b2)
0000:01:06.0 0200: 1113:1211 (rev 10)
0000:01:07.0 0400: 4444:0016 (rev 01)
0000:01:08.0 0180: 1095:3112 (rev 02)
0000:02:00.0 0300: 102b:2527 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [E]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


I'm trying to install Debian Sarge onto a SATA drive using a PCI SATA
card, the Silicon Image SiI 3112 SATALink. This seems to have caused
me a number of issues, which I'll list below:

1. Immediately after loading any 2.6.x kernel with the bootloader
before the kernel prints any messages there is a ten minute delay,
after which the kernel boots fine.
2. When loading the ide-detect module (2.4.27) or the ide-generic
module (2.6.8) there is a one minute delay without any progress.
3. Loading the sd_mod module fails (hangs) if ide-detect (2.4.27) or
ide-generic (2.6.8) has already been loaded. I solved this by running
the installation in expert mode and loading sd_mod first, then loading
ide-detect or ide-generic.
4. When using the 2.4.27 kernel, the installation hangs at "Starting
up the partitioner 38% Scanning disks..." I was never able to proceed
past this point with the 2.4.27 kernel. The 2.6.8 kernel worked
5. Rebooting with the 2.6.8 kernel failed. The reboot hung after displaying...
SCSI device: sda drive cache: write back
/dev/scsi/host0/bus0/target0/lun0: <3>ata1:
command 0x25 timeout, stat 0x50 host_stat 0x4
 p1 p2 p3 p4 <
Nothing further was displayed after the left angle bracket. After ten
minutes the screen blanked and I rebooted using crtl-alt-del.
I solved this problem by using the base-config installer module to
configure apt and install kernel-image-2.6.11-1-k7 2.6.11-7 from
testing and rebooting into that.

My installation, though frought with peril, now works! Thank you.


Reply to: