[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#250589: marked as done (May 22nd sarge_d-i CD images on sparc32)

Your message dated Sun, 7 Aug 2005 12:48:48 -0400 (EDT)
with message-id <Pine.LNX.4.61.0508071248210.5546@bobcat>
and subject line Closing old installation report
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 23 May 2004 23:54:02 +0000
>From jurij@wooyd.org Sun May 23 16:54:02 2004
Return-path: <jurij@wooyd.org>
Received: from mail0.globat.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BS2n4-0008UZ-00; Sun, 23 May 2004 16:54:02 -0700
Received: from stmaarten.globat.com (stmaarten.inside.globat.com [])
	by mail0.globat.com (8.12.11/8.12.9) with SMTP id i4NNrVwU083420
	for <submit@bugs.debian.org>; Sun, 23 May 2004 16:53:31 -0700 (PDT)
	(envelope-from jurij@wooyd.org)
Received: (qmail 75394 invoked from network); 23 May 2004 23:53:31 -0000
Received: from d141-170-139.home.cgocable.net (HELO ? (
  by stmaarten.globat.com with SMTP; 23 May 2004 23:53:31 -0000
Date: Sun, 23 May 2004 19:54:38 -0400 (EDT)
From: Jurij Smakov <jurij@wooyd.org>
Reply-To: jurij@wooyd.org
To: submit@bugs.debian.org
Subject: May 22nd sarge_d-i CD images on sparc32
Message-ID: <Pine.LNX.4.58.0405231823580.1589@bobcat>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: May 22nd sarge_d-i images from
uname -a: Linux debian 2.4.26-sparc32 #1 Sat Apr 24 00:12:33 EDT 2004 sparc GNU/Linux
Date: May 23rd, 2004
Method: Businesscard and netinst CDs, booted from a SCSI CD-ROM drive,
        using serial console.

Machine: Sparcstation 10
Processor: SuperSparc TMS390
Memory: 80MB
Root Device: /dev/sda: SCSI1 (0,3,0) - 4.2 GB FUJITSU MAB3045S SUN4.2G
Root Size/partition table:

Disk /dev/sda (Sun disk label): 16 heads, 135 sectors, 3880 cylinders
Units = cylinders of 2160 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/sda1             0        90     97200    1  Boot
/dev/sda2            90      3616   3808080   83  Linux native
/dev/sda3             0      3880   4190400    5  Whole disk
/dev/sda4          3616      3880    285120   83  Linux native

Output of lspci: pcilib: Cannot open /sys/bus/pci/devices
                 pcilib: Cannot open /proc/bus/pci
                 lspci: Cannot find any working access method.

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O/E] [Note 1]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O/E] [Note 2]
Install boot loader:    [O/E] [Note 3]
Reboot:                 [O]   [Note 4]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


1. The partitioner occasionally gets confused about the swap partition.
   See bug 250453 for a detailed description. The problem is not
   reproducible every time, but usually may be triggered by repeatedly
   deleting/recreating the partitions. In the installation above I have
   chosen the partition sda4 to be swap (and partman was displaying it as
   swap), but as a result it was marked as "Linux native" and no swap
   entry made in /etc/fstab.
2. The installer from businesscard CD still tries to install the 64-bit
   SMP kernel on a sparc32 machine, even though the corresponding
   32-bit image is available. This breaks the installation. The netinst
   install is fine. I'll try to investigate the problem by debugging
   the base-installer's postinst.
3. I've tried guided partitioning offered by partman and 'All files in
   one partition' option, recommended for beginners. As a result, two
   partitions, / (4.0GB) and swap were created. When it comes to
   installing SILO, it fails, claiming that the second stage boot loader
   is above the "magic" 1GB boundary, even though the base system occupies
   about 230MB. I am not sure whether this is a problem with SILO
   miscalculating the position of /boot/second.b or this file is really
   placed too far from the beginning of the disk for no good reason. It
   probably should be documented somewhere. Two ways to work around are
   a) to make a small /boot partition in the beginning, or b) keep the
   size or / (which should be in the beginning of the disk) under 1GB.
4. After reboot the pseudographics in debconf screens is screwed up
   (looked fine during the first stage), screenshot is available at

Netinst CD      - usable, completed the install, some minor setbacks.
Businesscard CD - ok up to base system install, then breaks by trying to
                  install the wrong kernel.

Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

Received: (at 250589-done) by bugs.debian.org; 7 Aug 2005 17:57:22 +0000
>From jurij@wooyd.org Sun Aug 07 10:57:21 2005
Return-path: <jurij@wooyd.org>
Received: from apollo.lunarpages.com [] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1E1oKO-0007QG-00; Sun, 07 Aug 2005 09:48:48 -0700
Received: from d141-171-204.home.cgocable.net ([] helo=bobcat)
	by apollo.lunarpages.com with esmtpsa (TLSv1:AES256-SHA:256)
	(Exim 4.44)
	id 1E1oKQ-0008Rn-0L
	for 250589-done@bugs.debian.org; Sun, 07 Aug 2005 09:48:50 -0700
Date: Sun, 7 Aug 2005 12:48:48 -0400 (EDT)
From: Jurij Smakov <jurij@wooyd.org>
Reply-To: jurij@wooyd.org
To: 250589-done@bugs.debian.org
Subject: Closing old installation report
Message-ID: <Pine.LNX.4.61.0508071248210.5546@bobcat>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - apollo.lunarpages.com
X-AntiAbuse: Original Domain - bugs.debian.org
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - wooyd.org
Delivered-To: 250589-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-0.1 required=4.0 tests=BAYES_44 autolearn=no 

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

Reply to: