[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

modprobe usbhid: sarge cd linux26

[DANGER!: This is not going to be the best bug report ever.  I
don't understand enough to do this right - feel free to ask me
for more info.]

Sat Jun 5 2005 - Downloaded "sarge" netinst CD, rebooted to my
brand new machine:
    Arch: i386
    Mouse: USB
    HDD: SATA (which is why I booted the install disk as linux26)
    # ...omitting what I figure are irrelevant additional specs.

The install process went well (by the way, good job, guys!  it's
been a while since I've gone through it, and there are lots of
great improvements), and I went ahead and chose "Manual" on

When it came time to configure X, I did "apt-get install
x-window-system wdm blackbox" and X refused to start, saying "No
such device: /dev/input/mice"

So I apt-get install'd usbmgr, and, ta-daa, it worked great.

Sun Jun 6 2005  - When I shut down my machine for the first time
to move it, it came back up without a mouse.  "cat /dev/input/mice"
gave no "No such device" error, but it also gave no data.

After some wrasslin' with it, and much help from #debian (thanks
'ethics'!), we discovered that I needed a "modprobe usbhid".

Adding usbhid to /etc/modules solved the problem permanently, of

So, I'm wondering if at some point during the install process
usbhid was probe'd into the system, but then wasn't added to
/etc/modules?  This is where my knowledge of the system runs out
- I have no idea which files to look through to find out.

I suppose I could just wipe everything and try the install from
scratch - that would definitely help the bug report, possibly
produce a patch, but I don't have the hardware/time right now.  I
hope someone with expertise in the install process can use this
report to some good.

Sorry if this is a red herring,

Reply to: