[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#311678: d-i doesn't like lots of SCSI disks

reassign 311678 
merge 311678 288129
tags 311678 d-i

On Thursday 02 June 2005 19:53, David Johnson wrote:
> The installation was going fine up until halfway through installing the
> base system. When it got to installing the kernel image and tried to
> make an initrd, it failed by saying that '/dev/sdi2 isn't a valid block
> device'. It was a valid block device because it had just partitioned it
> and created the filing system (ext3).
> I later re-tried the installation with the boot and root filesystems on
> sda, which worked fine, so I can only presume it was a problem with
> trying to install onto such a high disk ID.

The only problem is that by default there are no devices in /dev for more 
than 8 disks. This is a known issue [1].

You can work around it as follows: 
- install in export mode or with debconf/priority=medium
- when you get question which kernel to install:
  - switch to VT2
  - chroot /target
  - MAKEDEV the additional devices
  - exit the chroot
  - switch back to VT1
- problem solved.


[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=288129

Reply to: