[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307622: installation-reports

Package: installation-reports

Debian-installer-version: first RC3 
then daily build (2 May 2005) from 

uname -a: Linux mail 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005 i686 
Date: 3 May 2005 12:00 (Europe/Berlin)
Method: Netinstall from CD ISO Image with local Proxy.

Machine: ASUS AP140R-E1/AA2
Processor: Pentium 4
Memory: 3 GB
Root Device: 2x SATA Western Digital Caviar 2500 (Raid-1, Software Raid)
Root Size/partition table: 
#cat /proc/partitions
major minor  #blocks  name

   8     0  244198584 sda
   8     1  241207911 sda1
   8     2          1 sda2
   8     5    2988058 sda5
   8    16  244198584 sdb
   8    17  241207911 sdb1
   8    18          1 sdb2
   8    21    2988058 sdb5
   9     0  241207808 md0 
   9     1    2987968 md1

#cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/md0        /               reiserfs notail          0       1
/dev/md1        none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 82875P Memory Controller Hub (rev 02)
0000:00:03.0 PCI bridge: Intel Corp. 82875P Processor to PCI to CSA Bridge 
(rev 02)
0000:00:1c.0 PCI bridge: Intel Corp. 6300ESB 64-bit PCI-X Bridge (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 6300ESB USB Universal Host Controller 
(rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 6300ESB USB Universal Host Controller 
(rev 02)
0000:00:1d.4 System peripheral: Intel Corp. 6300ESB Watchdog Timer (rev 02)
0000:00:1d.5 PIC: Intel Corp. 6300ESB I/O Advanced Programmable Interrupt 
Controller (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 6300ESB USB2 Enhanced Host Controller 
(rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 0a)
0000:00:1f.0 ISA bridge: Intel Corp. 6300ESB LPC Interface Controller (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 6300ESB PATA Storage Controller (rev 
0000:00:1f.2 IDE interface: Intel Corp. 6300ESB SATA Storage Controller (rev 
0000:00:1f.3 SMBus: Intel Corp. 6300ESB SMBus Controller (rev 02)
0000:01:01.0 Ethernet controller: Intel Corp. 82547GI Gigabit Ethernet 
0000:02:02.0 SCSI storage controller: Adaptec AIC-7892A U160/m (rev 02)
0000:03:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:03:05.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet 

lspci -n:
0000:00:00.0 0600: 8086:2578 (rev 02)
0000:00:03.0 0604: 8086:257b (rev 02)
0000:00:1c.0 0604: 8086:25ae (rev 02)
0000:00:1d.0 0c03: 8086:25a9 (rev 02)
0000:00:1d.1 0c03: 8086:25aa (rev 02)
0000:00:1d.4 0880: 8086:25ab (rev 02)
0000:00:1d.5 0800: 8086:25ac (rev 02)
0000:00:1d.7 0c03: 8086:25ad (rev 02)
0000:00:1e.0 0604: 8086:244e (rev 0a)
0000:00:1f.0 0601: 8086:25a1 (rev 02)
0000:00:1f.1 0101: 8086:25a2 (rev 02)
0000:00:1f.2 0101: 8086:25a3 (rev 02)
0000:00:1f.3 0c05: 8086:25a4 (rev 02)
0000:01:01.0 0200: 8086:1075
0000:02:02.0 0100: 9005:0080 (rev 02)
0000:03:03.0 0300: 1002:4752 (rev 27)
0000:03:05.0 0200: 8086:1076

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]


Neither of the boot loaders (grub/lilo) could be installed on the RAID 
Devices. As a workaround I did the following (I hope I remember correctly):

* Started a shell from the installer after the boot loader install failed.
* did a: #chroot /target
* Manually installed grub from the install cd with dpkg -i /<complete path to 
the grub deb package>
* Created the grub directory in /boot/
* Created there a device.map: #echo "(hd0) /dev/md0" > device.map
* Did a update-grub to get a menu.lst in boot/grub/
* Ran grub and manually installed grub to both HDD's:
   root (hd0,0)
   setup (hd0)
   root (hd1,0)
   setup (hd1)
* After that I exited from the chroot and the shell
* Continued with the installer
* Reboot worked

After rebooting the networkcard wasn't recognized, so I had to install e1000 
per hand.

I had to do a little fine tuning to locales and install reiserfsprogs (which 
somehow didn't get installed), but besides that everything worked pretty 

After installing discover the networkcard is now recognized automatically.

I hope this helps.


Claus Grill

Reply to: