[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't boot floppy on PowerMac G3

I'm using boot.img from
sarge/main/installer-powerpc/20050305/images/powerpc/floppy on a
PowerMac G3 "Wall Street," family M4753.

Naively following the installer instructions ("place it in
floppy drive after shutting the system down, and before pressing
the power-on button") simply results in an ejected floppy and a
boot to MacOS. (Incidentally, the instructions refer to
boot-floppy-hfs.img, which appears to no longer exist, but I
understand the instructions are a bit outdated).

>From OpenFirmware, the command:
boot fd2:
(according to the NetBSD installation info, only the left floppy
works for booting on Wall Street machines, and it is fd2: --fd0
and fd1 give me errors about the device not existing).
gives the error:
DEFAULT CATCH!, code=FF00300 at %SRR0: FF80AFD0 %SRR1: 0000B070
I cannot specify a filename for the boot command as the floppy
appears empty in MacOS and, in OF:
dir fd2:
DIR method failed
dir fd2:,/
can't OPEN the DIR device

eject fd2: works, however.

I have also tried the rc2 images, with the same result.

How do I boot from the floppy?

Do you Yahoo!? 
Yahoo! Mail - Find what you need with new enhanced search. 

Reply to: