[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#301668: *** SPAM *** Re: Bug#301668: partman fails to create a prep partition, and falsely complains it is a ext3 partition.



On Sat, Apr 16, 2005 at 07:20:01PM +0300, Anton Zinoviev wrote:
> On Sun, Mar 27, 2005 at 05:36:31PM +0200, Sven Luther wrote:
> > 
> > The partman interface correctly marks the partition i created as prep, and
> > also correctly sets the prep flag on the partition table, but it complains
> > that the partition is an ext3 partition and has no mount point,

Thanks for helping out on this, i more or less abandoned trying to find where
the problem is here.

> There are two possibilities for a package like this.  First, to provide
> partman only with a method but not with an imaginary file system and
> Second, to provide partman with both.

Euh.

> Partman-newworld implements properly the second approach.  If you want
> to use it then the script choose_method/prep should be changed
> appropriately (see the partman-newworld package).

Ideally, all the partman prep|palo|newworld|whatnot, would share the same
setup, since they basically do the exact same thing with a few variation. 

> The first approach is simpler in my opinion but Colin Watson disliked it
> (I don't remember why).  Try the patch attached (the directory
> valid_filesystems can also be removed).

Ok, will, but will not have time before 2/3 weeks from now, since i will not
have access to the PReP box until then.

Friendly,

Sven Luther




Reply to: