[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian on a PowerMac G5

Hello everyone,

Just to update you all - and perhaps provide reward for anyone googling.

Gaudenz Steinlin suggested that the first stage yaboot (the ofboot.b
OpenFirmare script) was unable to load the second stage and that this
was related to me installing Debian on my second SATA hard disk.

"The root cause of this is probably that the ofpath utility does not
correctly identify the OpenFirmware path to your Bootstrap partition
(where the yaboot second stage is installed)."

Gaudenz was right in this respect and a confirmation to bug #294081
should be filed. Can someone please help me with this as I am unsure
of the correct procedure. The bug can be seen at

As an aside, to side-step this problem I simply installed Debian on my
primary disk - and everything worked like a charm. Everything but X,
that's for another list! ;)

Particular thanks goes to Sven for his help with my problems off-list.

Thanks guys!


On 4/3/05, Sven Luther <sven.luther@wanadoo.fr> wrote:
> On Sun, Apr 03, 2005 at 10:10:17AM +0100, Noah Slater wrote:
> > Hi Sven,
> >
> > The d-i worked and rebooted for me. Yaboot displays the standard
> > option screen with a choice of either "c" for CDROM or "l" for
> > GNU/Linux
> >
> > Selecting "l" yaboot just hangs for a while while a flashing question
> > mark/folder icon is displayed before simply reseting it's self.
> >
> > Does this mean a kenel problem?
> >
> > As per your request, hear are some of my system stats:
> >
> > Machine Model:        Power Mac G5
> >   CPU Type:   PowerPC 970  (2.2)
> >   Number Of CPUs:     2
> >   CPU Speed:  1.8 GHz
> >   L2 Cache (per CPU): 512 KB
> >   Memory:     2 GB
> >   Bus Speed:  900 MHz
> >   Boot ROM Version:   5.1.5f0
> >
> > Thanks for all the help!
> No, probably a bad yaboot configuration, you can look at the d-i yaboot.conf
> and the one generated after the install.
> Friendly,
> Sven Luther

Reply to: