[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#304181: CD-ROM cannot be mounted if piix module loaded

Package: installation-reports


Debian-installer-version: rc3
  http://cdimage.debian.org/pub/weekly/i386/sarge-i386-1.iso 2005-04-08
  (dated 2005-03-24)
uname -a: Linux ukko 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005 i686 GNU/Linux
Date: 2005-04-11 around 12:00 UTC
Method: Booted off CD number 1,
  downloaded packages from local mirror debian.hut.fi, no proxies

Machine: old, fairly basic desktop from around 1998
Processor: Celeron (Mendocino) 333 MHz
Memory: 256 MB
Root Device: IDE /dev/hda 40 GB
Root Size/partition table:

  This was a test install, still keeping my woody

                   First       Last
   # Type       Sector      Sector   Offset    Length   Filesystem Type (ID) Flag  Use
  -- ------- ----------- ----------- ------ ----------- -------------------- ----  ---------------
   1 Primary           0     2056319     63     2056320 W95 FAT32 (LBA) (0C) None  Other OS
   2 Primary     2056320     4048379      0     1992060 Linux (83)           None  unused
   3 Primary     4048380    61850249      0    57801870 Extended (05)        None
   5 Logical     4048380     5044409     63      996030 Linux (83)           None  old woody /
   6 Logical     5044410     6040439     63      996030 Linux swap (82)      None  swap
   7 Logical     6040440    14040809     63     8000370 Linux LVM (8E)       None  old woody
   8 Logical    14040810    22041179     63     8000370 Linux LVM (8E)       None  old woody
   9 Logical    22041180    30041549     63     8000370 Linux LVM (8E)       None  old woody
  10 Logical    30041550    38041919     63     8000370 Linux LVM (8E)       None  old woody
  11 Logical    38041920    46042289     63     8000370 Linux LVM (8E)       None  old woody
  12 Logical    46042290    54042659     63     8000370 Linux LVM (8E)       None  unused
  13 Logical    54042660    61850249     63     7807590 Linux (83)           None  /
     Pri/Log    61850250    80292869      0    18442620 Free Space           None

Output of lspci and lspci -n:

  0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 02)
  0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 02)
  0000:00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
  0000:00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
  0000:00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
  0000:00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
  0000:00:0a.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI]
  0000:00:0b.0 Ethernet controller: 3Com Corporation 3c900B-Combo Etherlink XL [Cyclone] (rev 04)
  0000:00:0c.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 0c)
  0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 01)

  0000:00:00.0 0600: 8086:7190 (rev 02)
  0000:00:01.0 0604: 8086:7191 (rev 02)
  0000:00:04.0 0601: 8086:7110 (rev 02)
  0000:00:04.1 0101: 8086:7111 (rev 01)
  0000:00:04.2 0c03: 8086:7112 (rev 01)
  0000:00:04.3 0680: 8086:7113 (rev 02)
  0000:00:0a.0 0401: 1274:5000
  0000:00:0b.0 0200: 10b7:9005 (rev 04)
  0000:00:0c.0 0200: 8086:1229 (rev 0c)
  0000:01:00.0 0300: 102b:0521 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [E]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [ ]
Reboot:                 [O]


First of all, I would like to thank everyone working on the installer,
and Debian more generally, for a great work!

I would also want to report a problem with detecting my CD-ROM drive.

I first booted off the CD with the "linux" or "linux26".
After selecting the keyboard layout, the installer tried to
mount the CDROM, but without success. I got the following error
message (perhaps with slight errors, recorded using a pen and paper):

  [!!] Detect and mount CD-ROM

  Your installation CD-ROM couldn't be mounted. This probably means
  that the CD-ROM was not in the drive. If so you can insert it and try

  Try again to mount the CD-ROM

When I booted with expert or expert26 and choose the module piix not to
be inserted when detecting the CD-ROM, everything went fine.

The CD-ROM drive (hdc: SAMSUNG SCR-3232, ATAPI CD/DVD-ROM drive)
does not seem to work with DMA under my self-compiled kernel 2.4.27
(from backports.org) that I currently use in the woody installation
that I run in everyday use on the same computer. I recall that under
the original 2.4.18, it worked. I have not yet had time (or motivation)
to investigate this very far.

Same thing now after the installation of sarge: If I insert a CD (and
something tries to mount it) I get error messages of the following type:

  hdc: tray open
  end_request: I/O error, dev hdc, sector 572
  Buffer I/O error on device hdc, logical block 143
  hdc: tray open
  end_request: I/O error, dev hdc, sector 512
  Buffer I/O error on device hdc, logical block 128

and the system slows down a lot, being busy retrying. After a
"hdparm -d 0 /dev/hdc", the cdrom works fine, but without DMA of course.

My installation logs are available at http://iki.fi/kenny/sarge_install/ .
They are password "protected" with username "guest" and password "egras".

Although I chose to install with the "expert26" option, I recall trying
the same with the "expert" option, which also worked fine if I chose not
to insert the piix module.

I also tried with the daily CD image downloaded on 2005-04-11 from
and had exactly the same problem.

A second note: I was a little surprised that no version of emacs
seemed to be included in the "desktop installation" (don't remember
the exact wording) of tasksel.  I guess that there is a good reason
for this.

If you have any questions, I would be happy to try to answer them.

			With best regards,

				Kenrick Bingham

Reply to: