[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#302988: IBM Thinkpad T43 hardware detection incomplete



On Wed, Apr 06, 2005 at 07:16:09AM +0200, Christian Perrier wrote:
> > Actually, I think that it is ata_piix.  I am attaching my working
> > 2.6.11.5 kernel config and the output of lsmod.  I am not using an
> > initrd image.  However, if I modprobe ata_piix and sd_mod, the
> > installer still does not find the hard drive.  I don't find any
> > entries in /dev/scsi either.  It does not help to modprobe all of the
> > other sata_* modules either.
> 
> 
> So, loading ata_piix should be the Right Way for discover when finding
> your SATA chipset but what you say it that this is not enough with the
> D-I kernel, right ?
> 
> So, this problem is dual:
> 
> -discover needs to load the correct module : easy to fix in pci.lst
I've added the missing information to pci.lst. 
> 
> -the kernel module must properly handle your hardware : not easy to
>  fix if this fails with the current 2.6.8-2 kernel we have in D-I
> 
> For everyone reading this : is this the correct conclusion?

I think this conculsion is correct. Horm: Is there any need to reassign
this bug to the kernel (if yes which package?)?

The only problem reported in this bug not yet solved is the second
network card:
0000:04:02.0 0280: 8086:4224 (rev 05)
0000:04:02.0 Network controller: Intel Corp.: Unknown device 4224 (rev 05)

Gaudenz

-- 
Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~

Attachment: pgptUclzDsLVe.pgp
Description: PGP signature


Reply to: