[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sparc d-i problem - unable to mount CD

Jurij Smakov wrote:

       Hello, good d-i folks!

       I'm trying to help with testing the d-i sparc64 CD's on the Sun
       Blade 150,
       which is at my disposal. First I need to state that on the
       machine there's
       a working Debian sarge installed already.

I tried today the latest debian installer 'businesscard' image.
There is a problem with it, the same as with the 'rc3' I tried lately.
The problem is as follows: installer CD boots fine and the USB keyboard
works very well (thanks again, Joey and Vince!), but soon d-i is unable
to mount the IDE CD. So I cannot follow the installation procedure,
because installer components are located on the very same CD :-(
It's like the catch #22...


What is your advice, then?

Hi Wiktor,

Well, whenever you have a sparc-related problem, checking debian-sparc could also help :-).

You couldn't be more right :-) I checked that already - a great source of
information indeed. Thanks for pointing this out!

This problem was mentioned there at least 4 times during
the last two weeks. It has been also filed as bugs #281243, #298927, #301480 against kernel-image-2.4.27-2-sparc64.

Thanks again for quick and informative response. That confirms my suspicions.
As I already wrote, the kernel I compiled myself (based on 2.4.27-8 source)
works correctly.

I have come up with the kernel config which seems to do the right thing,
however it is ABI-breaking and thus unlikely to make it into the final
d-i for Sarge. Since demand for these fixes is so big, I'll try to build
an unofficial netinst image, containing them - stay tuned to debian-sparc.

I'll be more than happy to test that on SunBlade 150. Could you please
Cc me when such image will be built? I wouldn't like to miss that.
Thanks in advance.

Best regards,

Jurij Smakov

Wiktor Wandachowicz

Reply to: