[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#302121: Debian Installer

Package: installation-reports

Debian-installer-version: 29.03.2005, http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/rc3/sarge-i386-netinst.iso uname -a: 2.6.8-2-386 (dilinger@toaster.hq.voxel.net) #1 Mon Jan 24 03:01:58 EST 2005
Date: 29.03.2005, 20.00
Method: I have tried to install Debian from the netinst-cd

Machine: Laptop FSC 8020
Processor: Pentium M
Memory: 1024 MB
Root Device: SATA
Root Size/partition table:
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [OK]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [OK]
Load installer modules: [ ]
Detect hard drives:     [E]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


My Laptop based on the intel 915 Chipset. The only Harddisk will be addressed by SATA. Unfortunately the kernel of the current Debian-Installer Version rc3 comes without support for it.
I can boot from the Debian-Installer-cd, but it doesn`t find any Harddisks.
So I tried the following to get it to work (on another laptop of course;-).
I mounted the iso-file:
mount -t iso9660 -o loop=/dev/loop1 sarge-i386-netinst.iso /stick/
After that I made a new directory /netinst an copied the files of /stick into it. Now I compiled a new kernel 2.6.11 with support for SATA a put it on /netinst/install/2.6/vmlinuz.
Last thing I did was to make a new iso-image with:
mkisofs -o new_image.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -joliet-long -P d
onde -r -V donde_1_0 .
I can boot from this new cd and the new kernel discerns the harddisk.
But it crashes later with the following message:
VFS: Mounted root (ext2 filesystem).
VFS: Cannot open root device "rd/0" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) So I believe that I forgot something in the new kernel. Everything in the new kernel was build-in. I have support for ext2, ramdisk. So I don`t know what`s wrong. Could you please send me the config file, which was used when building the kernel for the Debian-Installer-CD rc3?
Thanks inadvance
P.S. excuse my english, my school days are long ago ;-)


Reply to: