[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hard drive not detected with 2.6 kernel

On Wed, Mar 23, 2005 at 05:33:29PM -0500, Walter Landry wrote:
> Greetings,
> I have a new laptop, an IBM Thinkpad T43.  So, of course, I
> immediately started putting Debian on it with RC2.  The first problem
> I ran into is that the integrated ethernet card (Broadcom NetXtreme)
> was not recognized.  So I selected the tg3 driver, and it worked fine.
> Using the 2.4 kernel, I was able to install a new system.
> However, for various reasons I won't go into, I wanted to use the 2.6
> kernel.  Unfortunately, the netinst iso can not detect my hard drive.
> I get a "No partionable media" error.  I get a similar problem if I
> build a custom 2.6 kernel and use it on my 2.4 install.
> I have tried with "noapic nolapic" and "noapic nolapic acpi=off", but
> I still get the same error.  The hard drive is a Fujitsu MHT2060AH.

Find out what disc controller your laptop has.

I don't known if recent versions of d-i include 'lspci'


Where you have a working network connection "wget it"
and run:

  (lspci ; lspci -n ) | sort

and send us the output.

Also inform your hardware vendor that you want to run GNU/Linux on your

> Are there any other kernel options that might work?  I would have
> tried a daily build, but the link seems down.

And which link should be restored?

Geert Stappers

[1] Is  "Use a live CD like Knoppix for `lspci`" still the best advice?

Attachment: signature.asc
Description: Digital signature

Reply to: