[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#291144: marked as done (missing pci id for a ohci controller)

Your message dated Mon, 21 Mar 2005 22:47:16 -0500
with message-id <E1DDaMO-00037k-00@newraff.debian.org>
and subject line Bug#291144: fixed in discover1-data 1.2005.03.21
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 18 Jan 2005 04:59:06 +0000
>From clepple+debian@ghz.cc Mon Jan 17 20:59:06 2005
Return-path: <clepple+debian@ghz.cc>
Received: from ocelot.ghz.cc [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CqlSL-0003gY-00; Mon, 17 Jan 2005 20:59:06 -0800
Received: from www.ghz.cc (localhost [])
	by ocelot.ghz.cc (Postfix) with ESMTP id 26A16CC410D
	for <submit@bugs.debian.org>; Mon, 17 Jan 2005 23:59:07 -0500 (EST)
Received: from
        (SquirrelMail authenticated user clepple);
        by www.ghz.cc with HTTP;
        Mon, 17 Jan 2005 23:59:07 -0500 (EST)
Message-ID: <63949.>
Date: Mon, 17 Jan 2005 23:59:07 -0500 (EST)
Subject: [powerpc] [20050114] installation of d-i snapshot on Mac G4 Cube
From: "Charles Lepple" <clepple+debian@ghz.cc>
To: submit@bugs.debian.org
User-Agent: SquirrelMail/1.4.3a
X-Mailer: SquirrelMail/1.4.3a
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
X-Priority: 3 (Normal)
Importance: Normal
Content-Transfer-Encoding: quoted-printable
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: installation-reports

Debian-installer-version: 20050114 from
uname -a: Linux Carrera 2.6.8-powerpc #1 Sat Jan 8 22:01:09 CET 2005 ppc
Date: 2005-01-17
Method: sarge-powerpc-netinst.iso burned onto CD-RW
Machine: Apple Macintosh G4 Cube
Processor: G4, 450 MHz PowerMac5,1 (from /proc/cpuinfo: "detected as: 68
(PowerMac G4 Cube)")
Memory: 512 MB (2x 256 MB)
Root Device: /dev/hda12 (internal IDE hard drive)
Root Size/partition table:
:~$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda12             2533100   1751896    781204  70% /
tmpfs                   257684         0    257684   0% /dev/shm
/dev/hda14             6130880     36068   6094812   1% /home
/dev                   2533100   1751896    781204  70% /.dev
none                      5120       576      4544  12% /dev

Output of lspci and lspci -n:

$ lspci
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
0001:10:17.0 ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 03)
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:1a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394
Controller (Link)
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal PCI
0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth GMAC (Sun
GEM) (rev 01)

$ lspci -n
0000:00:0b.0 0600: 106b:0020
0000:00:10.0 0300: 1002:5046
0001:10:0b.0 0600: 106b:001f
0001:10:17.0 ff00: 106b:0022 (rev 03)
0001:10:18.0 0c03: 106b:0019
0001:10:19.0 0c03: 106b:0019
0001:10:1a.0 0c00: 104c:8020
0002:20:0b.0 0600: 106b:001e
0002:20:0f.0 0200: 106b:0021 (rev 01)

Output of lsusb and lsusb -t:

$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 05ac:0302 Apple Computer, Inc. Apple Optical Mouse
Bus 001 Device 005: ID 05ac:0204 Apple Computer, Inc.
Bus 001 Device 004: ID 05ac:9213 Apple Computer, Inc.
Bus 001 Device 003: ID 05ac:1002 Apple Computer, Inc. Apple Extended
Keyboard Hub [Mitsumi]
Bus 001 Device 002: ID 04cc:1122 Philips Semiconductors Hub
Bus 001 Device 001: ID 0000:0000

$ lsusb -t
Bus#  2
`-Dev#   1 Vendor 0x0000 Product 0x0000
Bus#  1
`-Dev#   1 Vendor 0x0000 Product 0x0000
  `-Dev#   2 Vendor 0x04cc Product 0x1122
    |-Dev#   3 Vendor 0x05ac Product 0x1002
    | |-Dev#   5 Vendor 0x05ac Product 0x0204
    | `-Dev#   6 Vendor 0x05ac Product 0x0302
    `-Dev#   4 Vendor 0x05ac Product 0x9213

Base System Installation Checklist:
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


* I had to use video=3Dofonly to get yaboot to work (black screen at boot=
The font is fairly hard to read (especially compared to the Linux fbdev
font), which also caused some problems. Is there any way to build a list
of machine types into yaboot to tell it to use 'video=3Dofonly'? (No
problems once I figured that part out.)

* The internal hard drive was detected, but I had to manually load
ohci1394, sbp2 and sd_mod to see the external FireWire drive.

* I still can't figure out how to get X to work. Below are some lines fro=
XFree86.0.log relating to the framebuffer:

(II) FBDEV(0): using default device
(II) Running in FRAMEBUFFER Mode
(**) FBDEV(0): Depth 24, (--) framebuffer bpp 32
(=3D=3D) FBDEV(0): RGB weight 888
(=3D=3D) FBDEV(0): Default visual is TrueColor
(=3D=3D) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: OFfb ATY,Rage12 (video memory: 768kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0):  mode "1152x864" ok
(II) FBDEV(0):  mode "1024x768" ok
(II) FBDEV(0):  mode "800x600" ok
(II) FBDEV(0):  mode "640x480" ok
(II) FBDEV(0): checking modes against monitor...
(**) FBDEV(0): using shadow framebuffer
(--) Depth 24 pixmap format is 32 bpp
(EE) FBDEV(0): FBIOPAN_DISPLAY: Invalid argument
(=3D=3D) FBDEV(0): Backing store disabled
(**) FBDEV(0): DPMS enabled

I will check some of the other X server options out later. This was with
4.3.0.dfsg.1-10. I also tried rebooting into OS X to try initial modes of
1152x864 and 1024x768, but both caused the above error.

Charles Lepple

Received: (at 291144-close) by bugs.debian.org; 22 Mar 2005 03:53:11 +0000
>From katie@ftp-master.debian.org Mon Mar 21 19:53:11 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DDaS6-00052d-00; Mon, 21 Mar 2005 19:53:10 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1DDaMO-00037k-00; Mon, 21 Mar 2005 22:47:16 -0500
From: David Nusinow <dnusinow@debian.org>
To: 291144-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#291144: fixed in discover1-data 1.2005.03.21
Message-Id: <E1DDaMO-00037k-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Mon, 21 Mar 2005 22:47:16 -0500
Delivered-To: 291144-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 2

Source: discover1-data
Source-Version: 1.2005.03.21

We believe that the bug you reported is fixed in the latest version of
discover1-data, which is due to be installed in the Debian FTP archive:

  to pool/main/d/discover1-data/discover1-data-udeb_1.2005.03.21_all.udeb
  to pool/main/d/discover1-data/discover1-data_1.2005.03.21.dsc
  to pool/main/d/discover1-data/discover1-data_1.2005.03.21.tar.gz
  to pool/main/d/discover1-data/discover1-data_1.2005.03.21_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 291144@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
David Nusinow <dnusinow@debian.org> (supplier of updated discover1-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 17 Feb 2005 19:05:39 +0100
Source: discover1-data
Binary: discover1-data discover1-data-udeb
Architecture: source all
Version: 1.2005.03.21
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: David Nusinow <dnusinow@debian.org>
 discover1-data - hardware lists for libdiscover1
 discover1-data-udeb - hardware lists for libdiscover1 (short list) (udeb)
Closes: 288522 291144 295704 299556
 discover1-data (1.2005.03.21) unstable; urgency=low
   * David Nusinow
     - Add 106b:0051 sungem Apple Shasta; Closes: #299556
   * Joshua Kwan
     - Add bridge/ohci1394 for 104c:8020. closes: #291144
   * Christian Perrier
     - Add bridge/ohci1394 for 104c:8027. closes: #288522
     - Add detection of Nvidia GeForce4 FX 4000 AGP 8x. Thanks
       to Otavio Salvador for the patch. Closes: #295704
 c4eaf3595d6f114437402d472f8d083c 742 libs optional discover1-data_1.2005.03.21.dsc
 e759763a61a8fed64ccc860a877364a2 102017 libs optional discover1-data_1.2005.03.21.tar.gz
 4911b6a14439ee44f0cd8f465f356f03 93108 libs optional discover1-data_1.2005.03.21_all.deb
 92e8aedda003bb2d2f47eb94e9c18300 16390 debian-installer extra discover1-data-udeb_1.2005.03.21_all.udeb
package-type: udeb

Version: GnuPG v1.4.0 (GNU/Linux)


Reply to: