[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#300719: sarge installer is unable to mount any drive (ide-cd, ide-disk, etc.)

Package: installation-reports

Debian-installer-version: sarge debian installer, iso image from:
uname -a:  <unable to execute uname>
Date: 2005 March 21st
Method: boot from cd image burnt on CD-RW
[power on, then] <Stop+A>
[OpenPROM] boot cdrom <Enter>
[SILO prompt] boot: <Enter>

Machine: Sun Blade 150 (with USB mouse and USB keyboard)
Processor: UltraSPARC-IIe 650MHz (sparc64 / sun4u)
Memory: 256 MB
Root Device: ? (for boot it's IDE CD)
Root Size/partition table:  <unable to execute fdisk>
Output of lspci and lspci -n:  <unable to execute lspci>

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O] great!
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [E]
Load installer modules: [E]
Detect hard drives:     [E]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


Initial boot is a pleasure. It just worked after pressing <Enter>
on the SILO prompt. No need to specify ramdisk size, or any other
esoteric options. Yummy :)

Finally my old problem (aka bugs #278215 <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278215> and #248855 <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=248855&archive=yes>) is now resolved
and the USB keyboard works. So I can test what else doesn't work.
And indeed, there are some issues.

Most important is that even though ide-cd and ide-disk modules are
loaded (via insmod - seen this on vt3/vt4), no expected devices are
present. The following directories are empty:

[vt2]# ls /dev/cdroms

[vt2]# ls /dev/ide

So, obviously, "Detecting installation CD-ROM" step fails miserably.

However, I noticed some message about hotplug being loaded, whereas
I couldn't see devfsd anywhere in the process list. Not being sure
what's going on, I'm filling this report.

Wiktor Wandadchowicz

Reply to: